Keyframing overwrites frames for one Bone on armature.

Hello, I have made a basic armature built from bones. I was in the middle of doing a run cycle, and out of nowhere one of my bones stops working. Every time I set a keyframe, it overwrites all other keyframes i have for that bone… But the rest of the armature’s bones are working fine.

I’ve tryed googling all over for this and can not find an answer.

Does anyone have any clue whats going on here?
If you need more information just let me know what you need to know, or I can send the blend file.

Thank you very much in advance!

Anyone have any suggestions of any ways to get this answered. I’m working on a minigame pack and this has put a huge snag in my work on one of the games. And i’m worrying it’s going to happen to one of my other important rigs, and i’ll be forced to stop on whatever game that is needed for.

Is there any suggestions on somewhere i can go to ask this question? Or is this the best place to ask.

I fear this is caused by something simple like me accidentally hitting the wrong hotkey, and i don’t want it to happen again without me knowing how to fix it.

This problem seems realy weird, when you create a keyframe (I guess pressing I) all the other keyframes are not supposed to be erased ; a keyframe just should be created at the current frame, eventually erasing the allready present keyframe.
What is your blender version ?
A .blend file may be usefull for us to understand your problem.

Hello Sliv! thank you for the reply. That is exactly what is happening.

I am using 2.56A and here is my blend file:

Actually, it doesn’t erase the other keyframes, they are still there, but they are now set to whatever i set the last keyframe to… (doesn’t matter if its in front middle or back, if i set one of the keyframes for that bone, it sets them all.

Or maybe it is not overwriting the data, but just not setting it and its reading some default position i’m moving it too.

Also it is the right arm bone (what would be connected to the bicep).

Gahh!!! !!! !

I had the little eyeball clicked in the graph editor… so it did not allow me to see the bones movement!
I’m such a fool, i was looking over every detail i could and missed something as simple as that
Thanks for the help though!