KIT OPS 2 Now Shipping

Cant wait to see this when its done. Proper Ferrari F1 era Nos. 27 & 28, Berger and Alesi. About the last time F1 was exciting.

1 Like

Saw your comment on Discord (answering here, easier and more peeps can benefit) to install a portable 2.8 blender. Your instructions are for the PC, I’m on a Mac - but I’m assuming file structure wise it’s the same. So I added the config folder in the 2.80 folder (after choosing Blender and choosing “open package” to reveal the file structure.)

When hitting “next” on the opening screen, I get an error that tells me the system doesn’t have write access to the new folder I made. I went into info and changed the permissions, but I still get the same error.

So the userpref.blend file never shows up in the config, and I’m stuck there, even though it seems it has read and write permission.

Edit: I tried setting the permissions one and two folders above as well, to no avail.

Thanks! I really love the cars of this era. :slight_smile:

I don’t have a Mac hooked up at the moment. Perhaps someone with one can offer some advice?

I ended up switching back to Windows a few years back as I needed to work in VR. Sadly, Apple refuses to play nice with Nvidia.

hi im on last build, this is the N panel with a freshly downlaoded kit ops from blendermarket, is this normal ?

Do you have a Masterfolder installed with KPACK folders?

Please take a moment and try and load the portable version of Blender 2.8 and install KIT OPS there and see if you still encounter issues. If not, then there is probably a problem with your current install or an addon conflict.

You can learn how to do install portable Blender 2.8 from this video:

Mac users may find this helpful:

More information on how to install KIT OPS and KPACKS


thanks for the support, it was just a simple folder mistake :sweat_smile:
but this seams more complex than my precedent case

what am i doing wrong ?

I don’t understand what it is you’re asking. It’s hard to debug from just an ERROR report. What platform are you on, what version of Blender, what version of KOPS, did you try portable build ???

WINDOWS10 on the current last master build 2.8.55 64bit with both kit ops 1.08 and 1.13 from bl market both give me thoses error messages systematically with every insert. also on portable build

So, when you tap the Add INSERT button, AFTER selecting an INSERT, you get the error? Can you describe the sequence of events you go through?

whatever i try, i get an error message when pushing add insert
i hope i did nothing wrong ?

edti: the gif share website make it too fast i hope you can see what im doing

if you want we can use teamviewer i have no problem with this

Well, I can tell from your gif, that is not the portable version of Blender. Please install the portable version and see if it works.

hello

i tried different configurations:
2.8 non portable with kits in the default emplacement
2.8 non portable with kits in my custom kit ops library
2.8 portable with kits in the default emplacement
2.8 portable with kits in my custom kit ops library

none of them work, all of them give me the errors as showed in the gif and prinscreens

my folders look like that for my custom library

as you can see kitOPS is detecting them, every single time i insert them i get the error messages

Chipp probably wanted you to use a clean version when he said portable. Extract the portable download and then add a “config” folder under the 2.80 directory before running Blender. Then try setting up the plugin and kits again.

You have no master folder. Please, review the videos I provided for you. You are not using the portable version as I can see a lot of other addons there in your library.

okay, i did run kit ops on portable and it didnt work but it was with a portable version of blender with all my scripts and ect imported in it

with a portable version and nothing imported from my main folder to the portable version it work
now im investigating what’s imported scripts do the issue

the start up file is the problem… i try to run kit ops witouth the start up file and it work file…
why on earth would an addon crash with a specific start up file ?

even if i try to run kit ops on this specific .blend it fail… this .blend is really important theres a tons of data i can’t lose …

Let me look into it.

1 Like

The startup blend file is a special blend file designed to configure blender into a preexisting state, these blend files specifically can often not be forward compatible and should never be used as a basis for a real project.

If you want the file to work you will need to open it and save it as a standard blend file, default.blend for example, this you can reload in a fresh factory reset, saving a new startup blend File > Save Startup File

You should be mindful of the limitations of the startup file, as it is not always forward compatible and it can crash blender in some cases after an update, although this entirely depends on the level of configuration by the user and the blender update in question.

As a side note you should NOT use a kitops insert file as a startup file, in particular when in FACTORY mode.

hmmm i see didnt know that startup blend file acted differently
im using the same file as start up since 2.79 do you advise me to do a new start up file from scratch ?
it may take me time but if it will prevent some bugs in the future its worth it, i saw some old 2.79 workspace data still in there