KIT OPS 2 Now Shipping

NEW FREE Andrew Averkin Hardsurface Kitbash Inserts brought to you by PixelUrge. Check it out, 500 Inserts to be used with KitOps! Absolutly FREE! Enjoy!


https://www.kit-ops.com/store/andrew-averkin-kitbash

10 Likes

Absolutely awesome generosity!

1 Like

This is a fantastic set of KPACKS. Thanks @Pixelurge !

1 Like

Just brought two awesome things together! Andrew Averkins kitbash set and Kitops and made them into inserts, which I must say work amazingly with Definitely EEVEE shaders!

Andrew originally had the kitbash kit on his site as obj and fbx files for Free. It was his generosity that allowed this to be possible! Everyone make sure to check out his site as well http://www.andrewaverkin.com

3 Likes

So, umm…

Traceback (most recent call last):
  File "C:\Users\Piotr Adamowicz\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\kitops\addon\interface\operator.py", line 244, in invoke
    insert.add(self, context)
  File "C:\Users\Piotr Adamowicz\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\kitops\addon\utility\insert.py", line 150, in add
    update.insert_scale(None, context)
  File "C:\Users\Piotr Adamowicz\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\kitops\addon\utility\update.py", line 210, in insert_scale
    init_hide = copy(main.hide_viewport)
AttributeError: 'Object' object has no attribute 'hide_viewport'

location: <unknown location>:-1


Please take a moment and try and load the portable version of Blender 2.8 and install KIT OPS there and see if you still encounter issues. If not, then there is probably a problem with your current install or an addon conflict.

You can learn how to do install portable Blender 2.8 from this video:
https://youtu.be/axNaU6mr6EI

Mac users may find this helpful:
https://blenderartists.org/t/how-to-create-a-portable-blender-2-8-on-mac/1154767/3

More information on how to install KIT OPS and KPACKS
https://youtu.be/ySvElx27ltU
https://youtu.be/wWo9J2v2sm0

It still throws the error when adding an insert on a fresh (blender-2.80.0-git.b1af68200159-windows64) portable install. There is no addon conflict because no other addons are active.

As for ‘a problem with my current install’, that’s nonsense. What would that even look like? A half-decompressed zip? Please.

It’s probably caused by this:
https://lists.blender.org/pipermail/bf-blender-cvs/2019-May/123131.html

You might want to have some humble pie and re-read the advice Chipp gave you. If it works in the portable version, the issue is with your regular install. That´s no nonsense, just common sense, and the most basic and common first steps in support.

You have tried in portable, it still didn´t work for you, that narrows down the number of possible sources for the error, and Chipp can move on to further troubleshooting. You might have pointed out the cause of the issue, which is very helpful, but everything between the first and the last line of your post was completely unecessary.

1 Like

I meant the phrase is nonsense, because it doesn’t actually mean anything specific you can check for.

It is, all instances of hide_viewport need to be replaced with hide_instance, at least if you are working with 2.79 assets in 2.80. It’s probably better to completely phase it out and use hide_set() instead.

Addon update required.

2 Likes

Wrong, the problem is you want more specificity, which isn´t always possible before basic troubleshooting, hence why it´s important to know if the problem exists in a clean Blender install, since that narrows it down.

I´ve actually worked in support for some 10 years, so I´ve had this discussion a couple of times with stubborn clients, which believe it or not increases the time required for a solution :slight_smile:

But I´ll happily bow out now. This seems like an easy fix. Have a good one :slight_smile:

1 Like

The API change was just undone, so there’s no addon update necessary after all, just a Blender update.

2 Likes

It could be several things. It could be a problem prefs, or startup file, or other addons. As @theApe has said, this is the first step in helping to diagnose your issue.

None of those are part of the installation is, yes? But nevermind. Came for support, not to argue.

Install in this case means your setup, it´s not an uncommon use of the word. Should be obvious in the context. Maybe there´s an issue of language here, and maybe a less ambiguous word could be used. Still not nonsense.

Not arguing. Your original install uses your default startup and prefs settings. These can affect how Blender runs. Installing the portable version uses fresh defaults, which helps to track where issues are.

I’ve always been wondering, why not just Factory Reset? It’s easier to do and achieves the same. It’s what I tell my customers.

Some people don’t want to change their prefs and startup file. Your point is a good one for Mac users as they have a difficult time with the portable version.

Loading factory settings doesn’t change anything, unless you save the prefs and/or the start up file after the reset.

  1. Load Factory settings
  2. Enable addon
  3. See if the bug in question can be reproduced
  4. Restart Blender with all the old settings still in place.
1 Like

Hmmm, really? Didn’t know that. Good to know!

I did have one user who was using an old startup file and Blender wouldn’t even launch. He told me it was because of KITOPS. Of course it wasn’t. He was really committed to keeping his startup file…