KIT OPS 2 Now Shipping

Use “Apply visual transform to mesh” under the object menu

New video showing how I do what you’re talking about:

I paid $35 for KitOps Pro, and now Chipp wants another $29 for KitOps Batch, functionality that should have been included in Pro. I don’t think so.

@chippwalters I am having an issue when attempting to convert the vent into something final for export. I am trying send someone the high res version for retopo and unwrap but they use maya. Is there an available workflow that covers using your tools for game asset development? I really like the tool but it doesn’t appear to allow me to "finalize an object for export. Thanks for your help.

Just as an FYI I have tried convert to mesh and apply. Nothing seems to merge the insert into my mesh or apply the modifiers. Thanks.

Try this (convert visual geometry to mesh)

Saying this nicely. :grin:

I understand the need to make dough, but can you just combine this with Kit Ops and call it Kit Ops 3 and charge accordingly? Even if it means everyone has to buy the new version.

I don’t like the precedent being set here; taking up precious tab space for something that’s just a feature for the already existing add-on.
If I’m correct the new extra add-on does nothing by itself and needs Kit Ops Pro to function. Meaning it’s just a function of Kit Ops.

Imagine if Box Cutter or others made a new tab for every new option it provides. :grin:

Please just include it with Kit Ops and charge as needed.

Thanks, Tim

3 Likes

Thanks for your comment. BATCH is not for everyone, that’s why it’s a separate product.

I’ll be updating it soon to be able to have the option of putting it in the KIT OPS PRO tab.

Our new product in testing, called KIT OPS BEVEL (which doesn’t require PRO) already has this option.

There are so many things Blender can do to fix this problem. I’ve recommended some of the fixes, but they’re not listening AFAICT.

Hopefully some day they’ll come up with something.

2 Likes

They do are listening, though it may not be available soon as they have to think about new UI concept or “force” addon developper to put the option for the user to chose where the addon goes.

Concerning Kitops, i have a request. Would it be possible to remove the automatique renaming of the assets ?
I work with precise naming convention, and creating an insert just breaks everything.
If i name my inset “ScrewHead_Flat” with a child named “ScrewThread”, it’s quite ennoying that when i create then insert it, they get renamed something like “Screwhead flat main” with child “Screwhead flat screw thread”.

Thanks :slight_smile:

1 Like

I’ll look into the renaming issue.

While not an optimal solution, can you try opening the .blend INSERT and rename it there?

Glad to hear about the option to combine. Having multiple tabs was my only concern. :+1:t2:

1 Like

I am one of those that don’t need it, so it suits me fine that it is a separate product, I’d be a bit miffed if it was bundled with KitOps then we had to re-buy kit ops when it adds a functionality I simply don’t need.

I think Chipp has done the right thing making it a product aimed at those looking to build and sell their own kit ops packs, not all of us want that.

1 Like

I know it’s been almost 2 years since you asked that question, but I had that same question. This is not KitOps’ fault, but the way Blender works. It’s a pity because face-snapping is a must when moving INSERTs around.

However, since when creating new INSERTs, snapping DOES work, perhaps there are under-the-hood methods, that KitOps dev could share or implement for moving INSERTs after their creation.

HEY i have shared a pack of 15 Free sci - fi cuttors , inserts and buttons kit-ops ready try it out its for free 15 Free sci - fi cuttors , inserts and buttons pack kit-ops ready

1 Like

Thanks! I’ll check it out :+1:

1 Like

youll want to turn that off.

2 Likes

Trying this tool now. I love the idea, but I am having a really hard time with it.

Specifically, I am trying to create my own Inserts. But inserts keep disappearing from the insert blend file, crashes when I try to render thumbnails, and all other kinds of instability.

Any ideas?

Sounds like a conflict of sorts.

Please try http://cw1.me/troubleshoot

Thanks, will have a look.

Just wanted to share my opinion on this addon.

The act of actively hiding simple truths and banning/attacking people for asking simple non provoking questions from your community with no warnings whatsoever, simply because the mention of github might lead to legal facts is a big no no in my book.
Sorry, but I do not agree with that type of manipulation, purposefully and actively taking away choice and keeping people naïve for monetary gain, nor with the toxic behavior.

My advice to all add-on developers.
Blender is a community about getting better together, be kind, support your users, so they can and WANT to support you.

My advice to all add-on users.
Support your developers! Add-ons, just like Blender itself, exist because you keep them alive, they need you. If you use them, please, donate to their cause.
But choose wisely which developer you want to support, which developer deserves your support.

Hello @chippwalters
I was quite confused (and a bit ennoyed) today when i discovered that some features just vanished from previous version of KitOps.

Where did the boolproperties Masterxeon pointed out earlier go ?
(Clean list name, clean insert names)

Where are the button for the display options ?

I tried reinstalling the addon, checked on several blender versions… no way.
By the way, could we have an option (in the preferences) to disable Autoselect (in anymode) and autoscale ?

Thanks