Knife snapped to 3D cursor issue

Hello all.

I have this recurring issue: the knife tool is fucked up because it is snaping to the 3D cursor. Visualy: the green square of the first vertex is located in the 3D cursor.
The tool is therefore useless, nothing is cut. No modeling possible.

I had this issue before, I think I solved it by switching from modeling to shading mode and back. How ridiculous is this. like dancing for rain.

If I start a new scene it is ok, the tool works on defaut cube.

But I cant find how and why in my actual working scene, so bored!

ok, have you check if the snap is enabled ? (I don’t think this would change anything but we never know :sweat_smile:)
Which version of Blender are u using ?
If it dosent’t change anything, could we have the .blend file ?


Snap is disabled, pretty obvious but yes, why not.
ALL_GCU_04_Knifefucked.blend (4.1 MB)

Blender version is 2.93.0
It happened on previous versions.

I dont think it is a bug but a misuse from me with some shortcut or a conflict with my french keybord… not sure.

Sorry for the laaaaaaate answer, :sweat: and more than that, I will disapoint you, I’ve being searching for a good thirty-forty minutes and find nothing, :confused:
I have the same problem, but can’t find a way to solve it, :sweat:
sorry and I hope you’ll find an answer :slightly_smiling_face:

Have a great day

I believe you are right…I can take it and open your file with Load UI unchecked…the very first time I saw the knife try to snap to the cursor but then acted normal…was able to use with out any problems… Opening with your UI active, I could’nt find anything that would cause this nor was I able to stop it from snapping to the cursor when clicking anywhere in the object…Sorry!

You can try re-opening your file and un-check Load UI and see if that stops it screwing -up in your system…only thing else you might need to do is to re-set everything back to the vanilla state…and what ever you like in the settings and re-save as your start-up file. You will keep your add-ons so that won’t have to be re-done…

Thank you Kazrarr and RSEhlers for your time.
the un checked Load UI has not made any result, I also installed 2.93.4.

the mystery thickens

1 Like

I got it to work, you had your far clipping set incredibly high.

I set it to 50000 and it worked.



Thank you! Yes indeed I am working on a huge scale scene.

I swear I tried that after I saw the crazy high input…
But can confirm it does work perfectly in 2.92…
Good job @a59303

Hey thanks.

1 Like

Wait, same, I change this but didn’t see a change :upside_down_face:, guess I did something wrong, again, gg @a59303

Try to setting it to around 10000 and see…I think I set the clip distance to .1 also…but not sure now…