Knife tool Cut through not working

Hi guy’s,

I just start using the knife tool and i ran into some issues regarding using the z key so we can draw all across a model but the end result is pretty bad on the other side as the gif show.

I tried applying transform and i did try it on a cube that didn’t had any transform and it did the same thing!

Also i cannot use the knife tool at all in perspective view?

So can someone be kind enough to tell me what i am doing wrong?

Did the same cube in 2.79 and the result are the same and i can repeat it as often as i want!

Am i the only one having issue with this?

Did some more test and i think this have something to do with depth since scaling the cube give better result, not perfect but miss less.

I played with the start clip and i try various scene scale and object size and it is still doing the same thing.

Starting to feel like a serious bug in the knife tool projection in my own opinion.

PS there is no modifier applied to the cube only simple loop cut.

Here a gif showing ;

It works fine here.
What exactly is the scale of you cube?

Hi, Lumpengnom,

The cube has no transform it’s 1,1,1. I include the file here and i am starting to wonder if it could be addons conflict?

I will do another test in a fresh blender without any addons to see if it is different.

knife_issue.blend (617.4 KB)

Works fine here with Blender 2.81 Alpha from the 15th of September.

I just download 2.81 and will try it in a few minutes.

I think it is a units or scaling issue.
In your file the unit scale is set to 0.01.
If I change it to 1 and then create a new cube it is create as a 200m X 200m X 200m sized cube.

I don’t know why this happens, though.

PS.: In you scene I can not use the Knife Tool in perspecitve mode either.

The manual states that the unit scale only influences the values displayed in the UI. Personally I would not change the Unit Scale to something other than 1 unless you really have to or else you might be working with extremely large or extremely small objects without realizing it. Extreme sizes can cause rounding errors and perhaps that is what happens in this case.

https://docs.blender.org/manual/en/latest/scene_layout/scene/properties.html?highlight=unit%20scale

Unit Scale
Scale factor to use when converting between internal units and values displayed in the user interface. This can be changed when modeling at microscopic or astronomical scales.

Note
This only influences the values displayed in the user interface and not how things behave internally. For example, physics simulations don’t take the unit scale into account.

Yes i also mention that perspective was not working with knife.

I just did a try in 2.82 alpha without any addon and with default unit and default cube in scene, i did a few loop cut and try the knife tool and again same result it is not working on the other side even while holding z that apparently is not working correctly since it’s trigger the shading mode pie.

Here my result ,

I don’t think you are supposed to hold the z button. Just press it once and it toggles “cut through”.

I work in real world scale and most of my game require scene to be set to centimeter for UE4 compatibility since 1 unit in UE4 equal to 1 cm.

On a stack exchange a solution mention that you need to hold down z while cutting for it to cut trough but i tried both way just hitting z but even with knife tool engage(cursor) it is only launching the shading pie!

Here what i have when knife tool is engage if i hit z i get the shading pie menu ;

Perhaps you could set the scale in the exporter instead.

I just found out that the perspective issue is a clipping issue. You Viewport Camera Clip Start is set extremely low. If you raise it to 0.01 it works.
Perhaps this can repair the broken cut through as well.

Will give it a try but i remember trying all sort of value for the clip start and it was still doing so.

The other reason i prefer centimeter is for easier spinning of numeric field since at default 1 meter unit the numeric field go way too fast making precision work a pain even while holding the shift key.

That’s weird. That is not what is supposed to happen.

Here i disable the z key for shading pie menu to see if z for cut trough in knife tool would work and it didn’t !

Like i have said this was fresh blender without addons with default settings so i am completely at lost but i saw a few post and thread on blender devs having a hard time with strange issues with knife tool.

It work correctly on one side but no way to have to cut trough it simply don’t want to do it correctly here.

I tried 0.01 in clip start and the result got a little better but still miss one edge here a picture;

I wonder if i should report this as a bug?