Knife tool going crazy

I just downloaded 2.8 after a long hiatus from Blender. It was going so well learing the new interface but them the knife tool started acting up. I tried appending the model into a new file but is still doesn’t want to work with this mech.

If this a bug or did I enable some feature?

tnah6.blend (772.7 KB)

Same here, the Knife tool is not new at doing strange stuff, and in this case doesn’t seem to be snapping to the polygons in front, but only to the one in the back, even if you scale up the model, which looks small, but that’s not the problem.

A solution is to use Connect Vertex Path

I also found that the knife tool never was as reliable as in e.g. 3DSMAX.
Sometimes it works as expected, just to fail on other parts, give strange erratic geometry and require manual fixing.

For me changing the camera clipping distance fixes the issues I had with the knife tool. Really weird…

Changing the clipping distance also works for me, not too low and not too high as shown on a youtube video. I hope they could fix this issue