Knife Tool is working overtime, calm down, Knife Tool!

I’m at this point in this tutoria:

But when I use the Knife Tool as instructed, it generates some polygons automagically, as in I don’t need to Join the lower vertices, it’s done for me, but it’s usually done badly.

Is there some setting somewhere that tries to avoid creating n-gons?
Why is the presenter’s Knife Tool behaving differently than mine?