Knife tool only cuts half of a cylinder

I’m trying to cut a cylinder with the knife tool.

I can make the cut alright, but it only cuts the underside of the cylinder.

ie. if a cylinder comprises 32 sections, only the bottom 16 faces are cut. The top 16 are unaffected.

This is driving me demented!

Did you enable the option (Z) to cut all the way through the object (knife options on the 3d view header when you are using the knife tool)

Please always supply screenshots and blend file so we know exactly what you are talking about

Hi Richard,

Thanks.

Screenshots attached.

Attachments




I think what Richard is asking is: Did you do this?


Shortcut hints for using the knife tool are displayed while using the knife tool. What this is telling you is that if you want it to cut all the way through you must enable that option during use by pressing Z.

Edit: It seems from your screen shot that you do have it enabled. So If you are enabling it correctly and it’s still not working out, the next place to look would be the geometry itself. In which case a .blend would be helpful.

I’ve sorted it.

For some reason, only the edges on the side facing the viewport are cut when I use the “knife project” tool.

So if, after I’ve cut the top half of the pipe, I move my “cookie cutter” curve to the underside of the pipe and then rotate my view (using 4,6,8 or 2 on the keypad) so that I’m viewing from the underside and then do it again.

Works fine.

Knife Project has a “Cut through” switch that should do exactly what you want (left hand “T” panel or F6):


Thanks for that.

That’s useful to know.