Knife tool won't work in Blender, please help?

I press k, and the knife tool appears, but when I click, nothing happens. I tried this on 2.49 and 2.48. There’s nothing wrong with my python either. I’m really not sure what the problem is. Can someone please help me?

Are you holding down the K key? I’m not sure how it works in 2.49, but that’s how it works in 2.57.

I tried that, and it still wouldn’t cut… I’m really not sure what the problem is…

In Blender 2.57, when you use the Knife Tool, you have to select the vertices which you want to cut.

Here is the procedure:

  1. Select your object. Press Tab to go into Edit Mode, or just select Edit Mode in the drop-down menu generally located on the bottom of your viewport (it could be on the top depending on your settings). Select the vertices. You can select all the vertices, or you can select an area of vertices. The Knife tool only cuts across selected vertices.
  2. Hold down the K key, then hold down the left mouse button and drag the mouse cursor across the selected area of vertices you want to cut.
  3. In the toolbar tab (which is located on the left side of the viewport, at least for me; press T while the cursor is over a viewport if you don’t see the toolbar tab, and it should come up) you can select one of three options: Exact, Multicut, and Midpoints. Exact makes your cut exactly as you draw it; the other two options approximate the cut (I myself am not quite sure how to describe them). When in doubt, experiment. You can always redo it.

P.S. What version of Blender are you using? My above instructions work for Blender 2.57

I am not getting you. Knife tool don’t work in Vertex selection mode.

Perhaps I wasn’t clear enough. You have to select the vertices in edit mode. That works for me. I’ll edit my above post.

Select the edges you want to cut.

Hold the K key down while dragging across the edges.

Use the T panel to change the type of cut.