L-system error in leafs generation

When I use the ‘Add’ button in L-system it crashes. It happens in Blender 2.34. In the DOS Window appears the following menssage.

Traceback <most recent call last>:
    File "Application.py", line 447, in bevent
    File "lsystem.py", line 298, in lsystem_build
    File "lsystem.py", line 233, in get_mesh
    File "lsystem.py", line 246, in get_branch
    File "lsystem.py", line 266, in get_branch
    File "lsystem.py", line 75, in add_leaf
AtributeError: 'module' object has no attribute 'Const'

I use Window$ 98, Blender 2.24, Python 2.2x and 2.3x

I’m using a version of neolsystem that I have translated to the portuguese language, but it runs nice in previous versions of Blender:

Delete your blend file and use this version :
http://jmsoler.free.fr/util/blenderfile/images/lsystem/neo_lstseed228.zip

jms I tried your version with latest CVS but then I get this traceback-

//styken


Traceback (most recent call last):
  File "Application.py", line 459, in bevent
  File "lsystem.py", line 297, in lsystem_build
    leafbank = Slider("LeafOrient ", 2, 210, 170, 190, 18, leafbank.val, 0.0, 90.0)
  File "lsystem.py", line 225, in get_mesh
    if save:  writeln(f,leafcurve.val)
  File "lsystem.py", line 243, in get_branch

  File "lsystem.py", line 27, in apply_force

  File "Matrix.py", line 8, in vec_scal_mul
TypeError: unsubscriptable object


Sorry, it seems you do not use the right blend file cause i have just made a test with the today cygwin compilation of the bf-blender cvs and all works correctly .

Aaargh, yes it works perfect, I was messing around with the blend files so I ended up using something totally different. Sorry for that %|

//styken