Hi guys, new to the forum. I’ve been using Blender for a while now, and now I’m using it on a newer computer. I have the newest verion of Blender and Python, but Blender lags when I use it. Lags really bad, no matter what it is I’m doing with the program there’s a 2 second window between clicking and it actually happening. I don’t know why. Any ideas on how to fix this before I pitch the whole thing out the window?

I apologize for posting this in this forum, but all of the support forums seemed to be oriented towards actual modeling instead of general problems.

Need more information

What graphic card and driver are you running, what resolution, what lags, the 3D viewport or everything?

The graphics card is an ATI Radeon Express 200. My driver is ati2dvag.dll, v. 6.14.0010.6727. My monitor’s displaying at 1024x768 32-bit. Every action I take in Blender lags, from scrolling in to zoom, to moving a vertice, to clicking on a tab at the top. Everything.

The problem is your ATI radeon 200, is it a PC?

You have two options, try diffrent drivers or get a Nvidia card, or one of the latest ATI cards, it’s a driver issue with how they support OpenGL

Yes, it’s a PC.

Thanks for the help. Much appreciated. I’ll try to do one of those. (As it happens, I have an GeForce 9800GTX laying around, but no computer case big enough to put it in.)