Laggy/Choppy Scrolling In All of UI

These are my specs, just to get them out of the way. They’re not a factor in this. My computer isn’t “too slow” or anything like that. Just trying to preempt garbage replies.

The Problem:
I just installed Blender 2.7, and much to my dismay, the entire UI is extremely choppy and unresponsive in a very specific way. Even though the actual 3D model rotates and moves around smoothly & with no problem, anything I do with my scroll wheel causes the UI to act up. It’ll freeze, forget my input, lag, etc. Scrolling in menus is laggy, zooming in and out of the render is laggy. Programs on my PC that DON’T have this problem include Palemoon, Steam, Sony Vegas, FL Studio, and Photoshop. Blender is the odd man out. Here are my settings:

Well folks, is this a common issue? Do you know how to fix it?

Bump. Guessing you guys have no clue.

You’re right. I don’t have a clue… yet. Most of these things aren’t solved on the first post (though I don’t know why anyone has helped yet).

What troubleshooting procedures have you undergone? Have you tried a different mouse? Have you tried re-installing and/or installing a different version?

If that isn’t the answer, those results would certainly help on this end, but considering the fact that this is a ressurected forum, you might be better off going to Blender’s website for help, or later on maybe even file a bug report.

hahahaha jesus christ

Alright, what do you mean by “resurrected forum”?