Landscape not in final render

hello: I made an animation with various elements including a landscape. Every thing well but then I applied some nodes to create a material on landscape. Now it is shown everywhere except on final render. Even on viewport-rendered view it is shown.

Whats is wrong ?

It’s kind of impossible to tell, unless you post your blend file, or some screenshots showing your settings, materials, outliner, etc.

Have you toggled any of these?

thank you Secrop, I just deleted all objects but the landscape and save file as other name in order to get an example for uploading. Then I tested and discovered the issue was caused because of on particles setting under Render I unchecked the Show Emitter checkbox.