Laptop seems to have bad OpenGL support; any fix?

I recently bought a new laptop. I used to use blender on a desktop, but I really need the portability, so sold it and bought a laptop. The laptop has Windows 8, a 2GB NVIDIA GT 740M GPU, 8GB of RAM, and an Intel i7.
It has been pretty good for blender, but at certain times, the entire screen will freeze, and, after a few seconds, a warning message will appear; stating that the OpenGL driver has lost contact with the monitor. Then Blender will close, irrecoverably.
At the points it has done this, the RAM was quite low in usage, and the scene was not particularly detailed. I’m using Blender 2.70, by the way.
Will newer drivers fix this? Will the official Blender release fix this? Or will I just have to put up with this and save often?
I never had this problem with my desktop, despite the fact it had only a 1GB GPU.

Hi, this sounds like a timeout detection error, windows “think” driver crashed and restart it while GPU is still work.
Blender can crash than.
Look here:

Cheers, mib.

Hmmm…I could disable TDR. Maybe switching to integrated might stop it.
Or maybe NVIDIA will release a better driver…

I have noticed this as well on my desktop. I think it is nVidia’s way of preventing all out crashing. Instead you get the message that tells you some kind of communication was lost but everything is ok.

On a laptop I would think cooling might be the answer. You could pull down the MSI Afterburner software and run it in the background. This software allows you to draw custom curve for the fan to cause it to turn on sooner.