Large HDR Image Won't Load

I am needing to convert some panoramic HDR backgrounds from to open EXR. I have been completely successful in converting the smaller (2000 by 1000) images in blenders image editor. Now I need to convert one of the larger ones (10,000 x 4000) and the images simply won’t load into Blender.

Blender doesn’t crash, Blender doesn’t complain, the Windows task manager does not indicate that the Blender process is doing anything at all. Blender just sits there when I try and open one of these HDR files into the image editor.

I have searched the wiki and this forum high and low for any indication of a size limitation for the image editor or anyone who has had this kind of trouble before, and have come up empty on both counts.

Can anyone help point out what I am missing?


Clarification: I am using 2.49b.




I’ve just tried opening a 10,662 x 5,331 image from that website and it opened successfully after a few seconds. I’m using 2.49b on Ubuntu 9.10.

Maybe the image you’re using is corrupt - try downloading it again.

Thanks for your reply.

I have downloaded the image again and tried it again – same exact result.

I open Blender and in the image editor window I open the file browser, select the file and click “open image”. The file browser window disappears and the name of the file then appears in the little drop-down box in the header of the image editor window, but the image never actually appears.

Are you using the 32-bit version of Karmic or 64? I am running this on windows XP 32-bit and I’m wondering if it is a 32-bit limitation. How much memory does it consume will when you open this in Karmic?

Thanks again for your help!



I’m using the 32-bit version. I’m at about 510 MB (including FireFox) when the image is fully opened, and there are no spikes in memory usage while its loading. I’m not sure why it’s not working on XP.

If I get a chance later, I might boot into XP and try again.


I’ve tried the same file from Windows XP and had the same problem as you - it wouldn’t load. An error message is displayed in the console. I’m no expert, but it looks like Windows is having problems allocating memory. It’s also greatly overestimating the size of the image and is complaining that it is in an unknown format.

It would be interesting to see whether 64-bit Windows would fare any better with these images. You might have to try another application or OS to do what you want to do.


I have a laptop with 32-bit Karmic and Blender and (though it does take a while to load the image) it does load just fine. So this appears to be a Windoze problem.

I suppose now that everyone has forgotten about 2.4x there is no point in submitting a bug report?