Lasso WITHOUT adding to selection?

You know when you work from the orthographic front & left views, you want to select verts and all the overlapping verts, so you can move them and keep them aligned?

In max that’s pretty easy, just drag a box around it and move. Repeat to move a different set.

In Blender I can only find;

  • Right click, which makes a new selection, but only selects one vert under the cursor.
  • CTRL-Left click for Lasso, which does select all the overlapping verts, but always ADDS to the selection. Meaning I have to keep pressing A to deselect, before lassoing a new set. I feel really slowed down by this.

It’s weird, because every other selection tool in the world makes a new selection by default, and only adds if you hold shift.

Edit: My bad. I thought Lasso Selection worked on same principles as Border Select.

Here’s new workaround.

Input in User Prefs;

Search for Lasso.
Scroll to 3D View, you’ll see two entries for Lasso.

Disable the first.
Expand the second.
Remove “Shift” modifier so only Ctrl is ticked.
Disable the options “Deselect” and Extend".

That’s it.

Ahh, you are a life saver! I’m adding this to my ever growing Blender notes. I had tried solving it myself prior but those settings are (and still are) a mystery (eg. why are there 2??) Still can’t understand why it doesn’t work this way by default, but I’m just glad to have it solved.

One other question then - the basic select is “right click” by default. I can see the value in right click to select, left to modify, helps when dragging the manipulator handles above a whole bunch of verts, but if they’re trying to pattern us into this, why then is Lasso and Box select etc. done with the left mouse button?? It doesn’t seem consistent…

Can we make the lasso (and box) trigger using the right mouse button instead of left?