Lattice Messing Up Normals

I am having a problem with normals when using a lattice deformation.

Background:

I create a Cube, scale it down in the z direction to thin it out and scale it up in the x direction so that it’s kind of like a diving board. I then apply 32 loop cuts to add some edges and vertices for deformation. Up to this point the face normals are all “normal”.

I then apply a lattice deformation which deforms the cube in the way that I want it to, but all of the normals come out perpendicular as shown in the image that I have attached. This obviously creates numerous problems with smoothing, etc…

Why is this occurring? What is the solution? Recalculating normals seems to have no effect since all the normals are, actually, on the outside already.

Thanks!

Mike

Attachments


Hi,

Apply Scale (CTRL-A, 1).

Thanks for the response, unfortunately, I don’t know what it means. :frowning:

Ctrl+A doesn’t invoke a scale and doesn’t seem to do anything by itself. Where does the ‘1’ fit in?

Mike

Select the mesh and in object mode press Ctrl+A and select the first (1) option in the list to clear scale and obdata.
When you are getting weird normal issues this is one of the main solutions to these type of problems.

Richard

Bingo.

Thanks to you both for the responses and thanks Richard for stepping this newbie through it. :o

Mike