Lattice problems

I have a lattice problem (Blender 2.54), when I put a lattice around an eyeball with a track to constraint, probably better to look at the image I guess


here is the blend



Looks like you scaled/rotated the lattice in edit mode. Restart with a new lattice. If necessary, rotate/scale it in object mode before using it as a modifier.

I done gone did that already and I checked the axis box and made sure the axis were pointed the same way.

Look, heres a simple fresh one from scratch, I move the target and the eye moves in its deformed shape

Are you trying to squash the eyeball flat that the lattice is so thin like that? Either way, your eyeball has a rotation and scale to it, and the lattice has a scale. Open the transform panel, N-key, and select each one to view. Clearing the rotation of the eyeball returns it to being flat with the pupil facing the pose bone. Since I don’t know what you are really trying to do, I can’t tell you how to clear up any problems other than getting the eyeball to be squashed flat along the world’s y-axis.



What I am trying to do is have a deformed sphere in the lattice representing an eyeball, the eyeball needs to be squashed although I emphasised that somewhat in the image and blend file and when I move the target bone, the black bit representing the pupil needs to follow the bone while the eyeball stays in the lattice cage retaining its shape and alignment. In short, I want an eyeball which is not round but still tracks to a target bone.

Try the attached .blend. First thing I did was apply scale/rot, ctrl-A, of the armature (had a rot of 360) and the eyeball. Then rotated the eyeball around so it was pointing forward towards the armature bones. Then I added a bone with the root at the center of the eye and the tip sticking out of the pupil. Parented the eyeball to the bone, select the eyeball, select the armature (both in object mode), entered the armature’s pose mode and parented the eyeball to the bone, choosing the make parent to bone option. Next, I added a track to constraint to the eyeball bone. Once the eyeball was tracking to the target bone perfectly, I added the lattice & lattice modifier to eyeball. Scaled the lattice down so it was about the right size, jumped into edit mode and scaled the lattice down to flatten the eyeball.

Generally, it’s a good idea to clear scaling/rotation of things when rigging. Also, objects origin’s should match, the eyeball, the armature, and the rest of the character should all have the same point.

Hope this helps,


eyeballs-lat.blend (296 KB)


Many thanks Randy,

I did try a fresh blend with all rots and locs cleared but still had the problem. I think its because I pointed the eyeball to the tracking bone directly and parented the eyeball to the lattice, I should have pointed a bone to the tracking bone and parented the eyeball to that.

I have a fairly flat face I want to but the eyeball on and cannot use a normal sphere.

The blend you attached is perfect. Perhaps someone should make an eyeball tutorial with thing like this in mind.

Thanks Again