Lattice troubles

This is my first time working with a lattice modifier, and everything goes smoothly until I type in the name of the lattice in Ob entry of the lattice modifier.

Then Fig 1. becomes Fig 2.

I’ve looked at the fork tutorial in the Blender wiki, and I can’t figure out what I’m doing wrong.


Try Parenting the object to the Lattice.
( CTRL+P with both objects selected, the lattice selected last.)
Select Lattice Deform from the submenu.

See if that gives the same effect.

What shape is the lattice?

I tried it, but I still get the same problem.

It’s a cuboid with the following settings: U:2, V:4, and W:2.

Do you want me to upload the .blend file?

This looks, as if you had edited the overallShape of the LatticeBox in EditMode before parenting the Modifier.
To Edit the Latticeshape to match your model without deforming, you should use scaling in ObjectMode.

So if you did the scaling in EditMode, this Change will be given to your model


Thank you, it’s working perfectly now.