Leaking lights

Hey it’s me again with my silly questions.

Anyway as seen in photo I can’t figure out why in game engine the lights are visible on the other side too and they don’t stop on the surfaces.

I’m having a bit hard time setting up lights on interior scenery since the rooms on other side of the walls also receive the lights from other side.

Should I bake the lights somehow via blender renderer instead of trying to use lights directly put in?

Attachments


It’s because shadows are not supported in realtime (except buffer shadows on spot lights- but they aren’t very reliable)

Your best options are to bake the lights (you’ll get much better quality and performance, but your lights won’t be dynamic), or to split each room into its own layer and set the lights to only effect the layer they’re on.

@Captain - They are reliable - you just might have to tweak the settings a bit.

The layer splitting method’s a good idea, and should work well. You can bake the lights in the Blender Render rendering system under the Render tab (camera) - which really should also be migrated to the Blender Game rendering system, as light / shadow / texture / normal baking are not Blender render exclusive.

I mean they aren’t reliable in that settings that are good on one computer, won’t necessarily be good on any other computer. I believe it’s related to the different graphics cards, but that’s just a guess.

Also, you basically get to choose either shadows that don’t quite connect to objects that are touching the ground, or shadows that leave artifacts everywhere. Neither option is particularly good looking.

While that’s true, using your idea would work well, Captain. An example would be putting buildings and larger objects on one layer and putting people and small objects on a separate layer (which doesn’t cast shadows). That would allow shadows to connect and also take the artifacts down.