Learning blender - hope somebody can help me

Hi! I am new to blender - just learning. Watched so many tutorials on lightning, camera setting but I am missing something.
My viewport looks good - I mean like a would like to (even in low samples) but my final render is very very bad (no mather how many hi samples I use). What I am doing wrong?
Ivana

Hi Ivana,

Hopefully, you’ve solved your issue but if not we can look at the simple stuff first. Check your lights to see if there’s one that is hidden in the viewport but visible in render. Like the “IES Light” in my example.

image

Hi Paul, I have checked that - noting is hidden. It is driving me crazy :sweat_smile:
I was using Skechup + Vray, but Blender has great features- I really like it.
Will keep trying to figure it out :slight_smile:

You share the .blend file here. If you don’t want to share the objects in your scene, you delete the objects and you save the .blend file with a different name and you share this .blend file. So other users can see settings and lights of your scene.

To me it looks like there is a lot of de-noising going on, try turning it off, you will get more noise (which you can render out with more samples) but you will not have those blotchy bits and will get a crisper image.

Please, do not share the file if there are elements there whose license does not allow it.
I am not familiar with the addon/nodes that you are using in World tab. Have you tried removing those World settings and simply using an HDRi instead?

https://www.youtube.com/results?search_query=blender+hdri+lighting

I will try with HDRi and post the result.

You are using NLM as your denoiser. Switch to Optix or OpernImageDenoise, which both give a much better result on this scene.

(And yes - I’m going to delete the file, not that I really have any use for ProSkies - I much prefer to work with HDRIs and my own custom setups).

Oh, and turn on adaptive sampling, which should let you push the sample count much higher if needed without the expected time cost.

Thank Yo for You effort! I will try every sugestion :slight_smile:


Thank You all for tips. This is a quick render, need more texturing and tweeking, but I am getting there :slight_smile:

1 Like

Look better.

You notice that in the scene there are mainly two elements bringing light from the outside. The World and the Sun lamp in collection 6. So if you still notice that the render is very bright, you should manage the settings of those two elements. Even maybe you want to use only one of them, for example World with a good HDRi (if you do your research you can find the nodes to rotate HDRi as you please)

Regarding Viewport looking different from final render, it could be related to your Color Management settings. If I remember correctly, there is still a bug where Viewport ignores Color Management settings (but I can’t remember if it affected Cycles as well).

Edit:
If you were only referring to patches/stains in the final render, this is due to what Roken told you before. Internal NLM denoiser is only useful for removing residual noise at very high render samples.

This is so helpful to me :slight_smile:
Your detailed instructions are just great. Will try tomorrow to adjust the light settings as suggested, You are right - it is too bright, I need to adjust light sources - will try to find nodes as suggested.
Roken tip about staines was also very helpful - finaly got rid of them!


Tnx again to all helping tips :slight_smile: This is a great comunity!

1 Like