Left Mouse Button Selection

hi all!

I using Blender with my new intuos4 (very exciting)

anyway, I change the selection method form RMB to LMB because I can select points, edeges and faces just tuoching the tablet.

the problem is that when I’m in this situation (see the image belowe)


but, when I push the point, blender by default, select the move pivot axis :ba:, I think will be better (like all other software) that just one click select the point and click+drag move the point.

I think is good that blender makes the people free to change the default mouse setting. but in this case the feature is totally useless :frowning:


ps: sorry for my bad english

If I understand correctly, what you need to do is go to user preferences—>Edit methods and click on "drag immediately Then just select your point, click on it again and drag away.
Heh, you don’t even have to click on the selected again, just hold down on the select button (after selecting) and drag.When you let up on the select button, your selection stays put.
Hope that helps

no is not that the problem , I want to select a ponti near another, but with LMB setting its pretty impossible :frowning:

I mean if you just try… you could understand in 1 second :smiley:


Well, here is a cube, subdivided 5 times then to sphere @ 100%. All I had to do was zoom in to select what I wanted. I guess that I don’t understand your problem. Sorry.

eheheh…ok, sorry too!

I mean. the problem is not the selction, the problem is when you have activate the manipulator and try to select the points near the manipulator axis…like in my figures… if the point is near the manipulator, blender gives the priority to the manipulator, not to the point.

I think will be better if just on click —> point priority click+drag—> manipulator priority (like all others softwares :smiley:

just that…


You can set that manipulator’s size and/or hotspot much smaller.

User Preferences > View and Controls > 3D Transform Widget

will try !

thanks :slight_smile:


perfect that solution seams to work good!

Larry beat me to it! Well, here ya go anyway…

Ahh, yes, now I see what you mean. If a point exists within the widget’s handle (or very close to it) and you try to select it with the left button (if you have swapped mouse buttons), it does seem to activate the widget rather then selecting the point, as in this example:

There are several things that you may wish to try. You can zoom in so the points are outside the widget’s hot spot:

Also you can adjust the size of the widget and it’s hot spot size in user preferences —> View and controls:
That or go back to right button select (no problems there) or just turn off the widget and constrain movements to an axis.

I’d just like to add to this that my productivity in blender went up about 25% since changing the default selection button from RMB to LMB. :slight_smile: (OK and changing MMB from rotate to pan, but then I’m working on a 2d game ;))

eheheh nice solution!!

thankyou to all!!