LeoMoon LightStudio for 2.8x and 2.9x

Same result, I don’t know why, maybe because of my drivers, it’s the quadro drivers.


Ziel, both ways. I use Win 8.1 Here.

I’ve just tested it on Win 8.1 and I didn’t have any problems. Did you install the addon to Blender installation path or to {user}\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\blender-light-studio?

Also, do you have problems with other addons? Have you activated any non-standard plugins that can make conflict?

Ziel, tried to install using both methods. None worked. Sometimes i got problems with other addons but always solved downloading the last version.

when I restore the factory settings the addon works, is it a problem with my blender settings?

Probably you had another addon activated that made a conflict. If you want, you can start activating your old addons one by one to see which one is cousing the problem. Then maybe I will be able to say what went wrong.

Did you get the build build.bleder.org or it was a custom build? It might be the driver or the build itself. Some builds don’t include the ability to use exr. I could just convert all exr to hdr. hdr is more common anyway.

hmm, still not working ziel. =/

I already tried to:

  • Turn off all my addons, and only activated BLight - Still not working;
  • Restore Blender to factory settings - Worked, but i lost all my preferences;
  • Restore keyboard shortcuts to default. - Not working also.

Edit: New errors.


Have you changed addon path or other paths in preferences? Can you restore to factory settings and than apply your settings step by step? Start with system paths, addons, then keybord shortcuts.
I have no idea which step may be the problem ;(

No, i haven’t changed any path in prefereces. =/

Where is the addon now? In AppData or in installation path? Make sure that
C:\Users\Thiagodesul\AppData\Roaming\Blender Foundation\Blender\2.75\scripts\addons\blender-light-studio_init_.py exists.

ahhh man i lost my last couple of hair.


I’m running out of ideas.
If you can’t find exact step after which things get broken, according to this http://stackoverflow.com/questions/27112876/solved-importerror-cannot-import-name-cant-figure-out-why
you can try changing your OS language to English.

It’s working, how i dunno. But it’s working now! Thank you so much Ziel!

If you guys haven’t noticed, we’ve just pushed a small bugfix. Current version is 1.2.3 now.

Thank you.
Although I have just started with Blender, I do have some Modo experience, and this add-on will certainly be very useful.

For info, if you want use this kind of map and not have this result.


You need to use a transparent shader and put the map in it.


Very useful tip. I want to add more types of lights. Like stripes, vertical/horizontal gradient lights, … I don’t know how to design the GUI to make it easy to understand yet.

Maybe you could add a popup to choose the light you want to use, it will be better than change the light after crating it.

Like this for the popup.


And add the good nodes to avoid the black effet I show in my first screen.