Lets talk about Mantaflow


(juang3d) #482

It will be built with 2.79 master, wich have some new features over 2.79, I´ll build it today and it will be on the mantaflow github, I´ll post the link here.

cheers!


(esimacio) #483

Juang, I tried to build the latest blender mantaflow branch put run into an error. Have no idea how to solve it.

" C:\blender-git\blender\source\blender\makesrna\intern\rna_smoke.c(750): error C4133: ‘function’ : incompatible types - from ‘WTURBULENCE *’ to ‘FLUID *’ (C:\blender-git\build_windows_Release_x64_vc12_Release\source\blender\makesrna\intern\rna_smoke_gen.c) [C:\blender-git\build_windows_Release_x64_vc12_Release\source\blender
makesrna\intern\bf_rna.vcxproj]"


(esimacio) #484

If any of you wonder about this error, Sebbas told me that this is a error in the latest commit, it is fixed but not yet pushed.


(esimacio) #485

Here is the latest build for those who are interested in it: https://www.dropbox.com/sh/ult55i7dmcyrt12/AAD7Ggn2NMdjbM3UIlAAdN5Ha?dl=0


(razin) #486

was looking for this, thank you


(juang3d) #487

Esimacio, I´m sorry I did not saw your post.

The build is already updated on github :slight_smile:

Cheers!


(esimacio) #488

Nott to be sorry about Amigo, It’s very good that you uploaded there. :slight_smile:


(English is not my native language) #489

Hello.
Has anyone tried compiling from mantaflow branch? Is Liquid simulation working for you?

Edit:
It is working now, I think I had misconfigured cache settings.


(juang3d) #490

Yes, of course.

What OS do you mean? In the github page you have the latest build for Windows X64.

Cheers


(English is not my native language) #491

Hi. I did not know that sebbas also had a repository on GitHub. I am using “fluid-mantaflow” branch of official Blender git repository. Are they the same?
I’m compiling in Linux by the way.


(juang3d) #492

Yes, is exactly the same.

I can’t help you with Linux builds, but Sebbas can, contact him on Twitter

cheers!


(English is not my native language) #493

@juang3d, ok. thanks.
Anyway, it is working now, I think I had misconfigured cache settings.


(jensverwiebe) #494

Linux build:


-- PACKAGE-INFORMATION --
Branch: fluid-mantaflow
Revision: 293a67c
Submodules: locale d3349b4 addons fbc03fd addons_contrib 3105780 tools 7695e14
OS: GNU/Linux, Architecture: x86_64, GLIBC: 2.19
Builddate: Mi 14. Mär 10:24:31 UTC 2018
Filesize: 84540316 byte
Sha256sum: 5eee5cc08036be26592a146c842fab2348885d18ec71054426088a8a1de49b64
URL: http://www.jensverwiebe.de/Blender/blender_fluid-mantaflow_linux64_latest.tar.xz

Jens


#495

Thanks a lot esimacio for that build!


(benediktus) #496

Hi, I am new to the forum and also relatively new to Blender. I just installed the Blender Mantaflow from http://graphicall.org/1199 (windows). I think it works really well except for the following: Every time I bake something, save and reopen the cache does not appear. I have checked the"use library path" and I know where the cache is located but for some reason Blender does not open it. I have selected the folder by checking “external” but nothing happens. What am I doing wrong? Sometimes when bake finishes no particles show up either (particle settings turned to visible).

There must be an easy answer for this, but I have no clue as I am still new in this field.

Thanks


(English is not my native language) #497

@jensverwiebe, Are you able to successfully compile with recent changes?


(jensverwiebe) #498

yes, change as temporary workaround:

diff --git a/source/blender/blenkernel/intern/smoke.c b/source/blender/blenkernel/intern/smoke.c
index b7ac09d..653fa16 100644
--- a/source/blender/blenkernel/intern/smoke.c
+++ b/source/blender/blenkernel/intern/smoke.c
@@ -586,7 +586,7 @@ void smokeModifier_createType(struct SmokeModifierData *smd)
                        smd->domain->cache_volume_format = PTCACHE_FILE_PTCACHE;
                        smd->domain->cache_frame_start = 1;
                        smd->domain->cache_frame_end = 250;
-                       BLI_make_file_string("/",       BLI_path_make_safe(smd->domain->cache_directory), BKE_tempdir_base(), "");
+                       BLI_make_file_string("/",       smd->domain->cache_directory, BKE_tempdir_base(), "");
                        smd->domain->cache_flag = 0;
 
                        smd->domain->display_thickness = 1.0f;

But as far as i can see, manta is nonfunctional atm…
Seems sebbas is still in the middle of something :slight_smile:

Jens


(English is not my native language) #499

Thanks Jens!

Oh, okay. Waiting to see what it is about :slight_smile:


#500

@ jens and yafu

that building stuff is all cryptic to me… but when you both successfully made a new build I would be very very grateful to both of you if you could somehow provide that for download. I just have no time to learn about that “how to build mantaflow” at the moment. It would be realy great from you guys!. I realy hate this translator and much more my language gap.Would be nice to play with new things sebbas did. Thanks and “sorry for that barbar words” !.. I?m an old person… English is not my language :wink:


(juang3d) #501

This is correct, Sebbas is working in modifying something big for Mantaflow, so right now is not functional, it will be soon, and the thing he is working on… it is pretty cool :slight_smile:

Cheers!