Lets talk about Mantaflow

@zeauro @Kologe @iponoo
It ‘nearly’ works! But it looks like the smoke gets different / incorrect WPP-RGB values compared to the meshes in the render-

You can definitely chose (volume mask) position in 3D space from the 2D render in Fusion, but it looks like the smoke is getting different / incorrect XYZ-RGB values from it’s shader, compared to the meshes.
Any ideas?..

@zeauro @Kologe @iponoo I think I’ve cracked it!

That video looks like the smoke is respecting the same XYZ-RGB coordinates as the rest of the scene to me. What do you think?
Basically divide by 100 seems to be the magic number, as in; divide the ‘position’ vectors by 100 before the RGB shuffling, and things seem to work-

Certainly seems to work well enough for me to use anyway!..

1 Like

Thanks for the file! I’m using 2.83.1 and it took over an hour to bake this file on a dual cpu xeon system. When all was said and done, I rendered a few frames and absolutely nothing showed up. Nothing was changed other than the cache location. Any ideas?

Did you bake particles, first ?
Anyways, that is a too much complicated file to be a good demo.

A moving emitter would probably have been a better choice.
I tried to make a cool animation quickly but I encountered bugs and released it under pressure.

I think I will share another one, now. More bugs have been solved.

Edit :
Here is a simpler demo.

0001-0100.mkv (586.6 KB)

manta_guide1.blend (749.2 KB)

1 Like

I have uploaded Part 1 of a compilation of Mantaflow settings - starting with the various emitter options. Maybe it’ll be of help to some playing with this new(ish) option in Blender 2.8+

8 Likes

How can I report random errors with Mantaflow liquids in the 2.82 release…?
I’m having crashes randomly when changing any value in the settings. Sometimes it crashes when typing a different resolution, sometimes the crash occurs when changing other values (FLIP Ratio, Particle Radius, CFL Number, Timesteps, etc), or it crashes when hitting the Fluid or Mesh checkbox… I don’t know how to report that because it is always a different setting which triggers the crash; the only consistent thing is that it happens when trying to do a liquid simulation.

That means that you have to continue investigation.

If it is the fact to change a setting that produces the crash, it may be another condition that produces the crash.
You have to analyze your scene. What makes it special compared to scenes that don’t crash?
Start with global conditions.
Is the culprit mesh of flow (ngons, modifiers) ? Is it related to resolution ? Is it related to a frame of animation ?

Basically any scene where I try to make a liquid sim crashes, new and old scenes.
So far I have tried with different scenes, both simple and complex and it crashes constantly, but the cause it’s always different.
But these random crashes happen only with liquid sims, not smoke, that’s the only consistent thing about them… sometimes is changing a setting, ticking a checkbox, or moving an object that causes the crash. I honestly don’t know how to report this.
Already tried to uninstall and re-install blender, but I still get the same errors. :upside_down_face:

So,with default cube, if you do Object menu -> Quick Effects -> Quick Liquid & press Bake Data button, it crashes, too ?
If you know that any liquid sim will crash, make the simplest one.

Launch blender in a terminal, a console with d as argument :
blender --d

Load Factory Settings.
Set Liquid sim. Save file at each tweak until crash.
When crash happens. A blender_crash.txt file is created in tmp folder.
Then, fill a bugreport following guidelines (precise OS, config, etc…) and join what you saved and blender_crash.txt to your report (don’t copy/paste its content, just attach the file).

And then, wait for a reply from a developer. If nobody is able to reproduce it on a similar hardware ; there is no warranty, they will be able to solve the issue.
But if the debug text is meaningful to them, they could solve it quickly.

Maybe they already have in master, did you try to create a liquid sim with a build from buildbot more recent than 2.82 ?

Yes, default scene with quick effects crashes too. I’ll try your other suggestion and see if I can get the crash txt file.

Thank you :slight_smile:

I had a tutorial problem with inflow working in 2.82, but worked if I did it in 2.83alpha. Quick liquid works fine for me though.

Blender 2.82 Mantaflow smoke settings examples part 2 https://youtu.be/NiNqtGORZBQ

3 Likes

Emitter vertex groups don’t seem to be working currently, or at least I couldn’t get it to.

This is release version and it looks like smoke simulation utilises my CPU pretty well, about 75%.


If I would run noise simulation, it will use all 100%.
The only messy thing I discovered for now is different colored smokes - somtimes it render with only one color, sometimes colors are different until mixing together and after “touching” each other they all turn to one color or to grey. %)
Terminating noise simulation immidiently crashes blender in 100 cases of 100.
That’s all for now… :thinking:

pS
Oh! And once blender crashed in the middle of some calibrations while performing noise baking.

1 Like

It works on linux, here.

I did not succeed to find a bugreport I read about color.
When there are 2 inflows and one is hidden for rendering, color is lost and simulation is rendered grey.

Just checked again -
new icosphere, F3 ‘quick smoke’
Then in edit mode, make an empty vertex group ‘Group’

Then the following settings for the emitter:

Bake, and there’s still smoke.

Well. There is smoke for an incomprehensible case (empty vertex group = smoke emission restricted to no part of mesh = no restriction).

Smoke emitted from Vertex Group selection but not from the rest of mesh is working.

I have no problem with using a weight group animated through dynamic paint, too.

It works with animall addon, too.

If you assign all vertices to a Vertex Group and set their weight to zero, result is no smoke.

1 Like

Using Mantaflow with the new Blender 2.82 release.

Trying to fill a 3 meter long tank with water, but the fluid sim only sloshes on the bottom of the tank without filling up, even after 800 frames @ 30fps… Inflow shoots from outside of the tank but within the Domain cube. Tried setting Liquid radius from 1.00 to 2.00, but still no fill. Tried resolutions at 64, 96, and 128 – no difference.

Tank is extra thick in order not to have FLIP voxel leak into the domain.

Do I need to up the Particle Sampling or the Narrow Band Width to get the tank to fill up?

TIA.

Maybe that will work.
You are right. If increasing particle radius did not change anything, maybe you are loosing particles because they are not enough per cell.
You also have to check minimal amount of particles per cell required and try to set it to 1.

Blender 2.8 - Mantaflow smoke settings examples - Part 3 https://youtu.be/ZS4Q5QTHS_0

5 Likes