LG 37LC2D not turning on!

I have recently purchased an LG 37LC2D TV from a garage sale for around $30. They said they didn’t have the cables for it. However, the power cable port looked exactly the same as the one in most (if not all, I’m not sure) monitors/power supplies. So I decided to take it because I already had the cable for it. When I brought it back home and plugged it in, The green LED flashed a couple of times and then it stayed on for a while, then it turned red after about a minute. It showed no image/audio.
So my question is; Is the problem from the cable I’m using or the power supply? And if it IS because of the power supply, how do I fix it?

Hard to tell.

Review the power requirements near the plug (voltage range etc.). There should be a label somewhere.

As you can see the LED at least, the device has power. Try to enable the on-screen menu. This works without any input.

I tried every button I could find but nothing was showing. So I figured it might be because the screen was broken. I attached a device via the composite cable to see if at least the sound would work, but it didn’t. it was as if the device (a game console with internal speakers) wasn’t plugged in to anything. I am now suspecting that it might be the power supply.

well, I can’t fix it. I tried a lot of things. The next logical thing to do is to sell it! XD
I put it on craigslist :stuck_out_tongue:

If you open up the monitor and find the first circuit where the power cable connects. It usually has about 5-6 quite large (physically) capacitors. These are typically the ones that break first. Try to see if they have leaked some fluid or are swollen. Replacing those will cost probably less than 5€, and it’s not very difficult to do it yourself.

Just Googled it, and this popped up

Basically, either power supply, or dodgy firmware. Although, you cant update the firmware yourself as it doesn’t power on, you’ll have to take it to a LG technician.

I replaced the faulty capacitor yesterday because I opened it up a few weeks back and I ordered a capacitor to replace the one with a dome head. but it didn’t change anything :c it still won’t turn on no matter what! And as said in the link provided by Phoenix492, I can’t change the firmware because it won’t turn on :c