LIB ERROR: object lost from scene


This is an error which I experienced today for the first time since I have been using Blender:

LIB ERROR: object lost from scene: ‘Scene’

Hours of work wasted. The car I was modelling simply vanished.
The attached dialog appears now every time I try to load the file in Blender 2.76.
I wonder how the model can be recovered.


maybe attach the file so someone can have a look at it =)

Yes, you’re all right. I attach it here.

Moved from “General Forums > Latest News” to “Support > Technical Support”

Please post support questions in the proper forum.

This exact thing happened to me today!

From what I’ve collected about this issue, warning like this means you lost the object but you still do have a mesh inside the scene. Create a cube or whatever and in ‘properties > mesh’ try to find your model/mesh for it. You should be able to see the model there.

In my case unfortunately, this didn’t help because all the hard work was pilled in modifier stack (maybe that was the reason why it fell apart) and it just got erased. It’s pretty scary cause no one is 100 % sure where this glitch is coming from. I’ve read it’s all about linking and appending objects but that’s just not true.

Just to give this issue more context, I’m attaching my own file too, maybe we’re gonna discover something here we’ve been missing.
Cloud.blend (843 KB)

Hi paya,

I tried your method in order to recover my model, but without success. Thank you anyway.

I really hope the blender programmers will be able to find a solution to this bug.

Did you save at any point during your process? If you did, maybe go back to another save? If you saved in the same file, Blender will save backups in the same folder with the extensions .blend1 and .blend2.

Hi Breagha,

I usually save working files (at least all of those which are important to me) every 2 min in the same file and, in case of a substantial modification, every 10 min in a different backup file.

In this particular case however, I was just trying a different modeling approach. It was just a trial, not a file for work. Therefore, I used the same file all the time. It took me few hours to accomplish the result. During the trial, I saved frequently as I said and I closed the file every time without any problem. The last time when I reopened it, the message “object lost” came out. FYI, the file .blend1 in the same folder produces the same error.

Then I guess you’re out of luck :frowning:

I had the same issue, but going back to an earlier saved file saved my hide… :confused:


Blender save on Quit…If You have auto save on…Even if the Blend file haven’t been saved.

Name is Quit.blend…And it is in the Temp folder You have set in user preferences.

Don’t think it will help with Your Lib error…But it’s have saved Me much time. If My blend1 flle not are updated.
I just go to the temp folder and load the Quit.blend and I have my lastest work in it…Puff Puff