Just tried installing Blender 2.32 on a pretty recent install of Mandrake 9.2. Followed the instructions on the online manual (btw, what do I do with the makefiles in the plugins subdirectories, the manual doesn’t mention them at all.) and when I try to start it (from shell) I get the error:

./blender: error while loading shared libraries: libstdc+± cannot open shared object file: No such file or directory

I tried using find to locate this lib and coudn’t find it. Isn’t it part of the standard gcc package?
While searching the net for a clue about this I found posts that seem to indicate Open office also requires this lib, and OO runs fine on my machine.

I also have 2.31a installed (from an RPM as I recall) and it starts fine.

I know I’m missing something simple, but am new to linux. Can anyone please enlighten me?


I did a quick google search for “libstdc+± mandrake” and got a link to an RPM that might help you:

the rpm is “libstdc++2.10-2.96-0.83mdk” and is for Mandrake 9.2



I hit send to soon!

The places that I usually look to resolve RPM problems are:

The groups site is nice because you can paste the error text into the find field, click go, and then you will find 8000 people asking how to solve the problem that you just had.

Also, if you have a big directory of rpms on a server somewhere (like I used to where I worked), you can figure out what package provides what with a simple script like this:
(just pass in the string that the rpm complained about as the argument on the command line, if all goes well, it will print out the package that provides the thingy you are looking for.)

for i in *.rpm; do
if $(rpm -qp --provides $i | grep $1 > /dev/null); then
echo $i

Found a solution :smiley:

inciner8, I had googled that rpm too, but the link is missing, only the name remains. The tip about Google groups was great! I didn’t know how all that worked. Very handy, Thanks.

Anyway, turns out that library is on the Mandrake install discs I think. I was installing WxPython from a RPM and it said it was going to install that library to satisfy dependancies, then asked for disc three. Could have sworn I checked that but must have missed it :expressionless: