light clarification

Hi
I’ve a textured door of whose edges should not reflect in the direct sunlight.
How can I avoid sun clarification of the color?
Many thanks
Michael

turn down the specular. check out the Specular Shaders page in Materials

If it has an image texture applied just click the shadeless button. Otherwise you can put all sunlit objects on the same layer as the sun and enable the layer option in the sun’s materials and put the door on a different layer. You may also use exclusive light-groups, render layer configurations, etc…

Thanks but its one textured ( and curved on the edges ) obj. as its moving ( aircraft door ) i’d like to leave it so. I could select only the texture parts which shouldnt get sunlight reflection and then?
Regards Michael

Bake the textures on, Ctrl+ALT+B, then enable the shadeless option. Notice the complete lack of self shadowing on the textured area. You’ll have to unwrap the mesh in order to use the baking option because it’s a UV texturing option. If you have any problems just hit me up. The shadeless option will still work without UV mapping but you can do a whole lot more with texture images once you bring them into the nodes than you can with textures in the textures channels.

For the example image I parted the faces to be textured, then made the material single user for the parted mesh, added a magic texture, unwrapped with smart projections, baked the texture onto an image (image>new in the UV/Image Editor window’s header), enabled the shadeless option, joined the meshes back together, removed doubles, and finally rendered.

Attachments


Well, learn something new every day :wink:

That’s the whole point of BlenderArtists. That’s the only reason I hang out in these forums. It keeps my skills honed and growing. I really enjoy the threads where someone throws a curve ball that takes me several swings B4 I learn to knock it over the fence. The Composition and Lighting forums are my favorites.

Hi
thanks but I can’t turn the shading off. I’ve put:

  • shadeless
  • and under shader all to 0
  • also there something like “cant receive shades” or such

but still. See the pic. If I put the color to 0 the white
gets black but still that’s not fine. Even trying to match
the colors doesn’t look good.

So I did select the texture region i want no light/shadow on
and parted, gave the new material with above settings…

Thanks again
Michael

You need to highlight the problem and post a better pic. It’s almost impossible to infer anything about the pic you posted due to the heavy jpg compression. You will not be able to match a shadeless texture to any shaded material or texture.

That white vertical stripe before the first window. That’s where the front door edge is. That’s ugly and depending on the sun location getting shaded or whitened.
I simply have a uv textured region where i don’t want this effect…but it doesn’t seem to work…
Hmmm how should i reproduce that…

added a magic texture,
?
unwrapped with smart projections,
?
baked the texture onto an image (image>new in the UV/Image Editor window’s header), enabled the shadeless option
?

Thanks