light problem?

Hi ther!

Im using the copy draw mode method for lighting my level. I only have on lamp in the scen but the whole scen gets lightened. And thats not what i want, i only want the area wher the ligth is to be lighetned.

How do i go on about doing this? Is ther anouther method i can use for lightning?
Is ther a good topic or tutorial for this?


  • use static lighting
  • give up

blender doesn’t have shadows, and the lamps don’t have a proper distance limit in the game engine

either you build your level to deal with that, or you use static lighting

by static lighting I mean non-light-sensitive faces and vertex colors

if you setup a light setup you like, you can copy the colors you see in shaded mode to the vertex colors with the “make vertex colors” buton

oki, that sounds like what i wanted in the first place! i have been using the blender engien now for 2 days… so the ligthning thing is a bit comfusing. But you made some things clear.


The thing is when i add my texture through UV/image editor the shading/lamp stops working in the 3d view…

Is this the right way of ading textures to the engien?

Are you sure that the face is set to respond to light? Cause it doesn’t really look like it is…It could be though…I dunno…

z3r0 d is wrong.

The distance lamps cast light can be adjusted in the game engine. Lamp, Area, Spot and Hemi have adjustable distance setting.

Lamps just don’t cast shadows, and the light go through all objects, but maybe one day that’ll be added.

Download this example:



use the “spot” lamp type and try different settings and positions.

I neglected to mention [or try] the “Quad” setting…