light through glass

Hi

I found out light doesn’t go through glasses in both internal renderer and cycles,
I rummaged some information and finally figured out that I have to turn off shadow options to make light penetrate transparent things.
I tested it myelf. With both iternal renderer and cycles, light doesn’t penetrate glasses if I use shadow option.

…So I have to use at least two lights to make ‘sunlight shines through my window’?
One is penetrating light from outside, one is an indoor light creating shadows?

It does work for Glass but you need 2 things

  • Make sure Caustics are enabled
  • Enable Multiple Importance for the Sun light.

And then you need a lot of samples :smiley:

multiple importance- check
…you mean relective/refractive caustics in render menu? - check

…I guess light comes in through the window a bit…but still a bit dark…

As I said, the trick is to disable shadow casting for the glass object, not for the light
Did you try the node setup I linked you to in my last post?

Oh, I think I didn’t understand what you’ve said…
…that node is… is that blueprint for a nuclear reactor?
Joking, I need to learn how to use node, I usually rendered with internal one.

I gotta digest things you’ve just explained,
Thx and I gotta test that nodes