Light through objects

Well, I’ve started to work with blender today and I tried to make this part of a marker (which’s name I dont know in English :X) transparent so you could see the nib inside it.
So I did that using a tutorial but then I saw that light couldn’t get through it so everything inside it is just black
Then I searched the net again and found out the solution was really easy: just to enable ‘TraShadow’ under ‘Shaders’
But it didn’t work :expressionless: and I have no idea what I’ve done wrong here:
Everything looks good to me :confused:

Any help is appreciated! :slight_smile:


Not sure if this will help but attached is a Blend file showing a mock pen with transparent shadows and hopefully you will be able to pick the file apart to see what it does.

Also which setting transparent shadows, you set it on the thing that will receive the shadows not the thing casting them. So if you wanted so a floor plane to get transparent shadows you would set it on the floor, not on the thing casting the transparent shadows (like a slightly foggy pane of glass for example).

Sorry if this is not what your after.


pen.blend (180 KB)

That’s what I was looking for!
now I got it to work,
Thank you :slight_smile:

simply, you have to enable trashadow on the materials that receive the shadow.