Lightflow and Linux


(mrunion) #1

First, let me say that Lightflow ROCKS. Linux does too!

Anyway, my quandry is this:

I am simply plying around with some standard things – glass, fluid, etc. I am trying to render a simple glass ball and see the different IOR effects on backgrounds and such.

I am using Eeshlo’s wonderful script. I know this is not a problem with his script, but when I perform an export using radiosity, MOST of the time the render will fail in Lightflow after calculating most all of the image. In Windows the render will complete.

Any clues? I will try to post a sample file in the next hour or two and let you see what I’m talking about.


(Eric) #2

What do you mean by “fail” ?

to lazy to wait for the sample :slight_smile:


(mrunion) #3

I have posted a sample file. This file renders fine for me in Windows (both
2000 and XP). This file fails in Linux. You can get the file from
http://www.bigpony.com/storage/guest1/lftest.blend.

To test the file, load Eeshlo’s LF Export Script. I am using the November
2nd version, but I don’t think it matters. Leave everything at the default
settings except for the following changes:

Radiosity: On
Radiosity Data: Save
Caustics: On
BlendFile Import: On
Image Size from Blender at 50% (160x128)

In the “More Parameters” section
Radiosity Calculations for Glass: On

Now export the script. It renders fine on Windows (the picture is VERY dark
and ugly!). In Linux (Mandrake 9.0) it locks up at about 43.6% of the final
calculation (the 160x128 calculation).

I don’t think the source code for Lightflow is available for me to try
compiling under Mandrake 9.0, so I can’t try recompiling it. I have noticed
that if Caustics are NOT enabled the render will work fine.

Does this help anyone in knowing what the problem might be? I am at a total
loss.


(mrunion) #4

I have done more investigation and I found that if I take the light above the “ball” out of the export and the light closest to the camera out of the export, the render will work fine.

If I put the light above the ball back in and play with the DIST settings I can sometimes get it to fail on the 160x128 calculations EARLIER, but I can’t get it to go longer. No matter what I do with the light closest to the camera I can’t change the failure point.

If I change those two “trouble” lights to regular lamps (not spots) it seems to have no effect. Appending _RAY to those lights also seems to have no effect (as I expected).

I don’t know what is going on and now I’m curious! I’ll probably continue to fiddle with it until I become either completely frustrated or actually have a “real” project I feel like doing. Anyone with knowledge of what could be going wrong, please let me know. I think not knowing is killing me! :smiley:

(Note: If you do get the picture to render it is VERY dark. The file is just a test of sorts and serves no purpose.)


(eeshlo) #5

I tried the blendfile and on Linux I seem to get the same as you, it seems to freeze when halfway the final 160x128 render. But it might only seem to do that, I didn’t wait really long enough. Anyway, the problem might be that you used blurred refraction. Try rendering without, seems to work for me anyway.

Besides that, you have all sorts of options on which are not very useful in this case. Blurred refraction is not much use if there is only a plain white background, blendfile import is only needed when you want to import materials that use textures, or export metaballs or nurbs surfaces, for any of the other materials this is not needed at all.
Switching on radiosity for glass materials is also not really useful, only in cases that the glass has some diffuse color it might make a difference, otherwise it will only add to the rendertime.
Saving the radiosity data is also only useful when your are going to use it again later. But in this case there wouldn’t really be much use as there is hardly any diffuse reflection.


(mrunion) #6

Thanks for the tips! I’ll try those. One quick question – blurred refraction – how did I “enable” that? Was it by NOT using “_RAY” or is it a default check box that I didn’t uncheck/check?

Another quicky: Radiosity is generally not needed with “glass” objects. Isn’t radiosity what causes the little “pinkish glow” that can be seen around the bottom of the letters in this pic:

http://www.bigpony.com/storage/guest1/renee1_320x240.jpg

Larger, 800x600 Image here.

I am really kinda “out there” on some of this radiosity/caustics/volumeterics stuff. Thanks for all the help!


(S68) #7

I quote eeshlo’s manual:

[color=orange]
<with eeshlo’s voice>The Emit value divided by 100 is used to set the amount of refraction/reflection blur. This range is so low because generally you wouldn’t want to have extreme amounts of blur, which would also make rendering very slow. You can control the sampling with the “Refraction/Reflection Blur” parameters in the Render engine parameters section </voice>
[color]

Radiosity isn’t necessary for glass & metals because they REFLECT light rather than diffuse it, hence they contribute little to radiosity… Anyway you can use it!

If you had used, then that pink might came from it

Stefano

P.S. Nice picture


(eeshlo) #8

Like S68 said, the emit value of the glas material was non-zero, which enables blurred refraction/reflection. When using material extensions, some parameters don’t have the same meaning as in Blender. Blender has no refraction parameters, so that is why the ‘Ref’ slider is used to set the IOR for example. Only when using regular materials (no extension) can you depend on them working the same as in Blender (except for SpTra which is used to enhance specularity).

To S68: Wow, sounded exactly like me :stuck_out_tongue:
Anyway, good to know that even the docs seem to be useful… :wink:


(mrunion) #9

I shoulda paid more attention to the reading! The dock was open to that section when I was working on the thing! I kept reading “shadow blurring” in my mind.

FYI: The picture sample above used both Radiosity and Caustics and has the glass radiosity stuff on.

Thanks again guys!