Lightflow Question


(mrmunkily) #1

I’m trying to render a completely enourmo file in lfrt. the final rez is going to be something like 1280x1024, but I have a problem.

I have 256 MB RAM and a 256 mb swap partition.

When I run lightflow, i can see the python process bloating to fill first 20 then 30 then 40 then 50 then the whole damn system memory. What the hell?!? is this a memory leak? Or do I just not have enough ram for such high resolutions. I’m able to render it up to about 800x600 and then the memory gets to be about 90% full before it finishes. but it dosen’t stop increasing while I’m running it.
ARRRGH. this is a uber-detailed image and I need the size to appeciate it. I want to post it on CGtalk but a piddly arsed little 640x480 image isn’t gonna cut it.

normally, I can render a GI scene with lightflow quickly, and I think that this ought to take about 2-4 hours to render att 1280x1024, if it weren’t for running out of memory.

when mem runs out the disk goes nuts and it tries repeatedly to shut down X and KDE.

now i’m booted in runlevel 3 to try and run it at the cosnole only… but it’s still filling ominously.

can someone else check to see if lightflow fills their memory too?


(S68) #2

Hi!

Most complex LF rendering (of mine) was a crystal calyce, with all features turned on, 1024x768 modelled with 65kvertexes 91kfaces, many heavilly procedural materials…

on my system with 512Mram (And Win 2k, sob :frowning: ) I have never had memory problems… but it used more than 300M…

Stefano


(eeshlo) #3

Hi Stefano! Welcome back!

MrMunkily: I just tried a quick (5 minutes) render of a relatively highpoly mesh at 1280x1024, and it didn’t seem to allocate more memory than it should, it actually seemed less than 100Mb. I guess it depends on the options you use, I didn’t use radiosity/caustics and/or volumetric rendering in this case, but I can imagine that Lightflow will allocate more memory in those cases, since it does a lot of caching to speed up rendering. You can try to set the LIGHTFLOW_SE_MEMORY and LIGHTFLOW_VE_MEMORY to lower values, it might help, but a side effect of that is that it will increase rendering times.


(mrmunkily) #4

hmm. I’ll try again tonight at runlevel 3. The gui gets all sluggish and usnusable otherwise.

I really wish japoco would opensource lfrt 2. and for gods sake release lfrt 3. it supposed to have been ready for almost a year now!


(Skates) #5

LFRT3?? wow, that would be amazing. Anyway, I’m sure you tried setting the cache KB amounts to proper levels, so what else could it be… My only advice is try increasing the size of the swap file, although that will be slow if it works. Maybe buy some more ram! haha! It might be possible to trim down the resource use of the scene by editing various things to use caching, but I really don’t know exactly how that is accomplished, I think you have to know coordinates of a bounding cube within the lightflow coordinates, which I assume is different than Blender’s