Lighting Flicker with Set Smooth Mesh

Hey there, I’ve got another question. Notice how in

this test,

the neck of the Lego man flickers with the changing camera angle. The man’s head is using the ‘set smooth’ feature. The flicker doesn’t happen without the ‘set smooth’ feature on. How do I fix the flicker problem?

hm, perhaps you could try to activate the “No V.Normal Flip” button of the mesh-panel in the edit-buttons and / or recalculate all normals outside (ctrl+n)

tab into the neck mesh, select all, and hit Ctrl-n to recalculate normals outside. Turn on view normals in the mesh editing panel to confirm. You might have to do it manually using W-flip normals.

The only way I could get the flicker to disappear is by both recalculating normals, and turning on the ‘No V.Normal Flip’ button. I’ll have to re-position some lamps in order to illuminate the neck correctly now, but I think my problem is solved! Thanks, guys.