Lighting flipped?

Somehow the mesh I’m working with ended up with the faces all backwards, so I did this: Edit Mode -> Ctrl+A -> Ctrl+F -> Flip Normals, And the result is seen in both attachments, what it should look like is in the second in green. Basically, the lighting seems to be all messed up. There’s no black at all, that’s all shadows – the hair is blonde. I’m guessing there’s something that I’m supposed to be doing that I haven’t lol. If anyone can point me to the right direction, it’d be greatly appreciated. P.S. I’m horrible with Blender, so you may want to give simple steps. :stuck_out_tongue:

Attachments



Something is wrong, but I don’t think it’s the lighting. Can you import the mesh of hair to a new file and test there as well? Is this UV Mapped? Could there be a setting changed in your uv calculation tab that is causing this? I would test half the mesh again with the flip normals or just ctrl-n for recalculate normals.

Curious, I hope you fix it.

The mesh looks the same on every export. In fact, I’ve somehow fixed in in Blender, but once exported it reverts back to as it was before.

Now, what I did to get that from what I did before was… Ctrl+F -> Face Mode Set -> Texture, Light, Two Side.

But, when I export it, it just ends up with the normals facing the wrong way, not being two sided and the lighting being all funky again.

To be honest, I’m not even sure how what I did fixed it.

Attachments



At least it looks as if you fixed it… looks good.

I didn’t though, that’s the thing… Every time I export, it reverts as if everything I did to fix it never happened.

What are you exporting to? Might be that the export format is reading the normals wrong. So you need to flip all normals when you are in blender and then export. Then it will look funky in blender but maybe not in the export.

You can recalc normals on inside (Ctrl+SHIFT+N) or outside (Ctrl+N)

You might also want to activate backface culling using SHIFT+T this way you will see all faces that are the wrong side either black, when you are in double sided mode, or transparent when double sided is turned off.

Netimmerse/Gamebryo .nif format. I’ll try your suggestions tomorrow and let you know if it helps.

Ctrl+N & Ctrl+A seemed to have fixed the normals flipping on export bit, and I figured out the problem with shading was mostly the game engine’s file format, I had to delete a NiBinaryExtraData block because hair doesn’t seem to use it.