Lighting problem!

How do you use lights?

I’m using a tutorial but it says press F5 in the buttons window(brings to the material edit). Then click on the yellow light bulb.

I see a yellow light bulb right next to the red ball. Is that what I’m supposed to click?

But when I click on it there is nothing inside, it’s completely blank.

Do I have to be in a specific mode? Like scene, or object, or redit, or shading, or logic, or script?


add a light (press space>>add>>lamp). this is automatically selected. now press F5 and see what’s inside :9

hope that helps a little


Something to always remember, to have the correct buttons display you have to have the object selected. And always be ready to hit the TAB key. This is the key that takes you in and out of edit mode and object mode.


What about shadows?

It only shows me two buttons but shouldn’t there be more?

Is there some kind of an inverse light that creates shadows that I have to add for the shadows stuff to pop up?

help on the shadow bit?

If you turn your Lamp into Area or Spot, other buttons will appear.
Shadows options are also available in Shader buttons with objects selected (because they are object sensitive not lamp sensitive), and can be set on and off in the render buttons.