Lighting Problems...

Hello,
I have been tinkering with blender, to make a basic minecraft animation for experience. I exported a world using jmc2obj, and imported to blender. First I had problems with the textures being blurry, and I had to edit every single texture to be non-blurry… (Is there an easier way to apply a change to all of the images at once?)

After I fixed (most) of the textures, I was having trouble with lighting… I am using Environment Lighting, and a Sun light source. The lighting seems to be blocked by transparent parts of the textures. I know I could set the background materials to receive transparency, but then I would have to do every single one.



You can see on the left image, what I get when I render. On the right, it shows a solid view in 3d editor. You can see that the texture extends out, although the edges are transparent. The torch has ugly shadowing around it, and the transparent part of the ladder makes the part behind it look black because it blocks light.

Again, is there a way to apply changes to all of the materials at once, and all the textures at once? For instance if I wanted to enable recieve transparency on all materials, and disable interpolation on all textures? It seems like there should be a way to do this that I don’t know of… (I’m a blender noob)

Thanks in advance for any replies I get. If you need more information, please ask!

I assume it could be done more or less instantly with a short Python script, but I’m not up to date with the API and I’m not sure off of the top of my head how to code it, but the pseudo-code would look like:

for each object in selected:
for each material assigned to the object:
set Receive Transparent to True

Very easy, and I’d take a stab at it myself if I had the time

All right. I will look into the scripting part of blender. Thank’s for the tips!

id probably model this torch :).