Lighting via VertCol [Make]

I’m incredibly happy to have recently learned this techique(by following most threads in here…lurky lurky), but I can’t seem to master its use just yet.

For large rooms, I find it works great, but when I try to use it for hallways or tunnels I get a light on faces in areas where I don’t have any lamps, simply because those faces happen to be aligned with lamps.

I have been able to correct this a bit by turning on “Sphere” in the edit(now materials) light options and tinkering with the distance value, but the lighting isn’t as smooth.

I have turned on the “shared” button in paint menu, and that doesn’t smooth it out much, and I’d rather not have to add anymore faces then I need to.

Is there something I am missing? Or do I simply need to apply VertCol[Make] to small sections at a time in order to acheive my desired lighting?

Thanks in advance for any advice.

set quad1 to 1.0, and quad2 to 0.0, I think. If that doesn’t work, use 0 for quad1, and 1 for quad2. This is all in the light settings.

Thanks Lemmy.

Quad works much better then Sphere, while I don’t understand why, I’m glad it works : )

Sphere only works when rendering, it does nothing in the game engine or for vertex colours. Quad1 and 2 set how quickly light fades with distance from the light.