Lights Affect Mesh Strangely

Title says it all. I have 0 idea what is causing this.

  1. Select your mesh. Enter edit mode and select all faces.
  2. Press ctrl + shift + n (recalculate normals) and uncheck “inside”.
  3. Maybe set the autosmooth angle to a higher degree?

Just wild guesses. If it doesn’t help maybe upload the file.

Thanks for taking your time to respond!

It looks like it solved it in some parts, but created it/left it alone in others?

Is the mesh fully closed? Or are there maybe holes or manifold faces inside your model? Hard to say without looking at the file. Try merging vertices with a very small treshold maybe.

I’m afraid I’m not sure what you mean. (I’m mildly new to Blender, so I don’t fully understand a lot of things.) Would you mind having a look at the .blend?

I am currently on the go but i’ll have a look when i am home.

Thank you so much!

I am really sorry, but i couldn’t find the error.

Which parts are affected strangely? Can you circle them?

For sure upper teeth have flipped normals.

Here’s what is causing this:



with .2

Hope it helped.

Turn on display of face normals in edit mode, and check they’re all pointing outwards.

This is BEYOND helpful. Thank you so much!

Try setting the normal map to Non-Color Color Space.
Jeezus what a character, who’re you’re gonna scare? :smiley:

LOL This is for a meme.

Here’s the finished product! Thanks so much, everyone!

Yeah, the biggest thing to watch out for about “faces” is that there is no “back side” to them: if the normal-vector (which defines which is the “front” side) is pointing “away from you,” there is nothing there.

There’s no need to type what already has been typed, not to mention that the problem has been found and fixed. :wink: