Lights & layers


(DAK) #1

If I have certain lights, is there a way to tell them to not light up a certain layer on render?


(Goo) #2

There’s a button in the lamp buttons that says “Layer” on it. Click on it and the lamp will only effect the layer that it’s in.
If there’s one layer that you don’t want the lights in, you’ll need to put everything else in a layer with the light, or just duplicate the layer light and put it in each layer except for the one where you don’t want a light.

Goo


(DAK) #3

For the project I am working on, this just is not a working solution :frowning:
Ohhhhh why can blender never get my basics even? :frowning:


(haunt_house) #4

HEY HEY HEY…

Won´t you please insult my little favourite 3d-Program…

There is a solution for this:

Copy the lamp with alt-dkey and activate the layer function. You will have two lamps with one data block (and one name).

So If you tweak the settings, both lamps will change. Now put the first lamp on the first layer and the second lamp on the second layer. This should work.

I would parent the lamps to an empty, so you can move them all together.

Good speed

HH

mmm… how will I celebrate my 50th, now that I´m a groupie


(haunt_house) #5

Sorry DAK

I haven´t used the layer function very much, and I never played around until you posted.

It is even simpler.

You can let a mesh or a lamp appear on multiple layers, if you select them with SHIFT. Select the lamp and press f9-key. Select your Lamp and then Shift-select all the layers in the edit Buttons except the unwanted one.

There you go

HH


(DAK) #6

Haunt, you should try to play with the light layers. You are missing our point entirely. Yes, I know about the simple easy layer stuff you mentioned, but we are discussing the lamps own layers, which is seperate. For example, what if I have all my normal layers filled in a scene, and want the objects in one layer to not be hit by my light. It would be nice to have my light avoid that layer, just like environment mapping has an option to not reflect what’s in a certain layer.
Working layers and lamp layers work very differently.


(haunt_house) #7

Sorry

Did you try it out? I mean I can only tell you what I found out. And if you turn the lamp-layer on on layer 1 to layer 19 and activate layer, the lamp will not shine on layer 20. Layer 20 objects will remain dark if they are not lighted by other lamps.

And I do not mean the layer buttons in the 3d window, but the layer buttons in the edit window below when the lamp is selected. Because they decide which layer(s) the lamp is working on.

After your question, I set up a scene with three balls on three separate layers and two lamps. All the 3dwindow layers were ON, but I set The left lamp to layer 1 and 2 and the second lamp on layer 2 and 3. If I now activate the layer function, the left and the right balls get each one shiny point and the middle gets two. If I deactivate the layer function, all balls get two reflections.

Maybe my english is really really bad, but I thought you wanted to get lamps to avoid layers and having them work on all minus one is avoiding one layer…

I don´t know where the mistake is, but I can put out the light of a specific lamp for a specific layer with blender 2.23

No offense meant.

If I explain too badly, I will post a blend and two pictures.

screwtalker Haunt_house


(theeth) #8

You’re both arguing about the same thing, saying the same thing a different way.

DAK: yes, the feature you are looking for is indeed the layer button in the lamp buttons window, just like Haunt was trying to explain you. It makes the light only shine on the layer where it is present. You can change on what layer an object is in two (2) ways:

  • in the edit buttons, the classic two row of buttons symbolizing the layers. The one pressed are the layer that object is on, and vice versa.

  • you can press the MKey, and the same two rows of button will pop in the air. Be sure to press OK, not just slide the mouse off the pop-up, or it will cancel the action.

You can always select multiple layer by holding Shift.

Martin


(DAK) #9

Maybe my 2.23 has a bug. I keep trying this with same result. I have sphere on 3 different layers. Then I edit the light so it shines on one layer, but then it lights up everything on the other layers, and not just the one.
I will keep playing around and see what happens.


(DAK) #10

I finaly figured out what was wrong. There is another button called ‘Layer’ withint the lamp settings. It was confusing because there was so many different layer buttons being talked about.
I think you all for helping me to get through this. I learned a new feature now I hope I will never forget.
Thank you.


(theeth) #11

ok, not it’s my turn to be lost… where do you see another Layer button in the Lamp settings?

Martin


(DAK) #12

Select your light, click on the Lamp button. Now, click on the button called Layer.
The only problem I have now is my lights all are in the way when im modeling on 19 of 20 layers. But at least I can get it to do what I want now.