Lights off still rendering?

Was trying to islolate lights to tweak some shadows and discovered that although I’d turned some lights renderability off in the outliner they were still rendering, turning all the lights off and they’re all still rendering!!! No Light Groups active in the Render Layer’s panel, no Environment Lighting or AO or anything like that. Why are they still rendering? Can anyone help shed some light on this please?

No .blend no help.

Do you have texture on your objects? Check to see under Materials buttons, Shading, Shadeless turned on or not.

Did you just click the outliner eye icon instead of the camera icon next to the object entries?

If you did, then the only thing that changed is whether they are visible in the 3D view, not whether or not they are rendered.

Hi all, thankyou for your responses so far. Having trouble uploading the .blend file, is only 2.5mb. I get an error message: “upload of file failed.” Otherwise: Yes there are textures on the objects, no shadeless is not turned on. Camera icon (render) on lights is turned off. If I put the lights on another layer, and that layer is not visible, the lights don’t render. If I set the lights Energy to 0 works, but that’s not really practical when trying to tweak the lights. Perplexed.

Post your blend file here http://www.pasteall.org/blend/

http://www.pasteall.org/blend/7209

Hopefully help is still around, I’ve been busy with other things.

It think you may have found a bug.
If you remove your lights from the groups, then the switches in the outliner take over and work as they should.

Hmm. That’s a little frustrating then.

Thanks Atom.