Lightwave importer request.


(3Dre) #1

The lightwave importer doenst import 2-point polys (edges) anymore in 2.40alpha
I get runtime error: faces must have at 3 or 4 vertices.
The importer from 2.37a does import these 2-point polys.
Can someone fix this?


(Gabio) #2

if it’s bundled with Blender. Go to the bugtracker.
It will be more usefull: http://projects.blender.org/tracker/?atid=125&group_id=9&func=browse


(uaraus) #3

Hi 3Dre,
with 2.40alpha2 there’s a chance you are using Lightwave + Material importer.
I’m working on it and solved (just discard any face with less then 3 vertexes).
I’m also experiencing problems importing PATCHes (subsurf setting not working any more, at least in my case).

The fix is part of a major re-writing to deal with some speed and reliability issues with very large models.
95% done, still performing some test & debugging (it happens, having a daytime job :D) before being released.


(LetterRip) #4

you should be able to add an edge instead of a face, or just add verts without adding a face. Ask on the bf-python list and I’m sure someone can tell you for certain,

LetterRip


(3Dre) #5

I’m working on it and solved (just discard any face with less then 3 vertexes).

Well I, want to import 2 point polys :slight_smile: So don’t discard it, just import it.
Its a function I realy miss.
I use lightwave to import 2d-dxf(only 2-point polys) files and then import the saved lwo-files.