LightWave to Belnder Animation Workflow

This topic has been discussed in another of my threads. But since I seem to be having some issues with this I thought I would start another thread to this specifically.

My pipeline:

I created an animation with bones on a character in LightWave. I exported the vertex data in the form of a .mdd file.

I imported this character, then imported the mdd data into the mesh and it creates a sequence of RVKs into the shape key tool.

Playback of the animated mesh is perfect.

Problem # 1 - Cloth.

How then to get the cloth object of a skirt to follow the RVK data in the character mesh and have it pinned at the waist. Pinning of course locks the points in world space leaving the dress waist behind as the character moves. If the character was being deformed in Blender by Armature, of course this is simple but it is being deformed by Shape Keys so…

Solution I chose that seemed to work:

I went back to LightWave loaded up the skirt object set it to be deformed and translated with the bones, saved this as a .mdd file and imported the skirt and the .mdd file into Blender and it animates perfectly and follows the body.

Now I apply cloth with fixed points at the waist and the fixed points (that are also part of the shape keys) follow the body as expected and the rest of the points are deformed by the cloth perfectly based on the settings, collisions, self collisions and all work perfectly.

Well almost.

Problem # 2 - Apparent bug(s).

So I am not surprised as this seemed too good to be true. I have had many things go wrong while working with the cloth. Just strange anomalies like two sessions with exact setting produce wildly different results such as the cloth seeming to have no gravity or weight and flying up in the air more than expected with inertia. This would be with default settings of Cotton where in the session just before this, the same default settings worked flawlessly.

This and a few ther similar things that are strange and having worked with 3D animation software for 15 years I am OK with. Suff happens. Reset and do it again. Programs are not perfect. And I can not unfortunately track down what I am doing that is causing these strange things.

My basic workflow is to have a low poly cloth object and apply a subsurf modifier in the stack before the cloth to raise the mesh density to get nice cloth deformations with folds etc. Also set smooth is invoked on the cloth object material. Unfortunately I can not apply the subsurf level to the cloth object with the shape keys applied. I suppose this makes perfect sense.

So typically I will during my sessions do the following:

Delete and reapply the cloth to get back to the defaults.
Change the sub surf settings.
Rearrange or delete and reapply modifiers in the stack
Alt a to run the simulation
Readjust cloth settings
Change Sub surf levels
Alt a to run sim again

Pretty much things that I consider to be normal working conditions during a session with this work flow. Somewhere in here I am hitting something that is causing the various bugs and things. Not sure what it is.

Problem #2 - major reoccurring bug.

One thing that has happened repeatedly and I am not sure what triggers it but I am doing nothing more than the tasks listed above, is that I run the simulation and the fixed points do not follow the body and stay in position.

No solution, removing the shape keys and reimporting them, removing the cloth, reapplying any of the modifiers in the stack, nothing gets the scene back to normal functionality. The only thing that works is to recreate a new scene from scratch.

Then someplace doing the “normal” functions described above, this will inevitably happen and it has happened about a half dozen times.In other words if I do anything other than simply set up the scene and run the simulation once, this - along with many of the other problems - will occur.

I am at a loss to figure out how or why.

The only thing I can think of is that using the shape keys must be a mistake in the work flow. That somehow this is not really a workable solution.

The other possibility I can think of - and this would be a shame - is that perhaps I would have to go back to the LightWave object, subdivide it to a dense mesh level import that and a new high density .mdd to go with it into Blender and remove the subsurf from the stack completely.

Other work flow questions:

It seems that Blender - just as in Lightwave by the way - makes hash out of even a highly subdivided subsurf mesh during a cloth simulation and renders are full of artifacts unless another subsurf modifier is applied also after the cloth modifier. Typically in Lightwave I will displace a mesh of quads using cloth and then apply subdivision after this in the “stack” so that the render is smooth.

In Blender with the above work flow I run into a strange set of problems:

  1. Setting “Set Smooth” to the cloth after the simulation has been run erases the simulation cache and it has to be run again. So for some reason set smooth effects the object at the mesh level. In LightWave this would be only at the material level. No problem. I can set smooth first. Just different work flow and worth commenting on.

  2. Adding any modifier after the cloth modifier in the stack resets the cloth simulation as well. This makes no sense to me at all since the simulation should be running on the modifier prior to the cloth object and any modifier such as smooth or subsurface would be applied after the fact. I am not saying this is wrong or anything. Just saying I don;t understand how this works in Blender or why.

So this makes this work flow very sketchy at best. I can not apply the subsurf to the object and remove the modifier from the stack.

This means that all the modifiers before and after the cloth have to be in place before running the simulation and that no changes can be made post cloth in the stack without running the simulation.

Fine. But when I set it up this way, all hell broke loose. Another one of those strange bugs I guess.

So this makes for a very stultifying work flow.

Ideally I would like to set up the low poly object, try different subsurf levels, different cloth settings - and when I find the setting I like - run the simulation one last time. Then have this simulation in disc cache and saved with the scene.

More ideally I would like to render the cloth simulation as it is, and if there are artifacts in the render, readjust the modifiers in the stack post cloth modifier and render again without having to redo a simulation - which can take hours.

And making matters worse, there is no way to export a vertex animation of the cloth object such as .mdd and load that back into the cloth object because it seems to only save the vertex information from the base mesh pre-subsurf and loading it back in only makes hash out of the cloth object. So there is no way to solidify the cloth simulation and then run modifiers after the fact to smooth out the cloth for rendering - and thus save having to run the simulation again.

So this would mean again, going back to the cloth object in LightWave, making a predetermined call on the density, exporting that, then running a Blender cloth simulation on it. And then that vertex information could be locked with a new .mdd shape key set that modifiers could be added to. To me this is a very stultifying work flow.

OK so after all of that. What am I doing wrong?

Clearly I am very new to Blender and there has got to be something am I missing. Or it could be that I should scrap this idea of trying to port the animation from LW into Blender to run cloth? All I wanted to do was run a side by side test and after a week of simulation in Blender I have gotten 0 results with the current work flow.

I could I suppose use the higher subdivided mesh from LightWave but I am not sure that would eliminate all of the other problems (bugs?) I have been experiencing.

So rather than going another week with no results, thought I post the problem here and see if there is another way or if anyone can point to something I have missed or not understood.


So I finally got to the parenting section of the manual. And I was able to revisit the idea presented in another thread to parent to the points of the character object. I don’t know why that did not seem to be a solution before. I should have experimented with it but for some reason Shape Keys seemed to be working.

However I have eliminated a very large part of the problem by simply parenting the skirt to 3 points that define a flat circumference around the waist of the character. With the waist points of the skirt pinned it works and follows the motion of the character’s waist. Now I can do the skirt without shape keys and so far seems to eliminate most of the trouble I seemed to be having and it turns out it may have been due to the shape keys conflicting somehow with the other modifiers.

I hope that is right. :o