Limit rotation for a bone issue

I thought that would be an easy way to limit the rotation of a bone but it seems I was wrong

What is the best way to lock / limit rotation for a mechanical rig?

It seems such a simple idea and it frustrates me that I have some issues here.

http://dl.dropbox.com/u/239525/bone%20rotation.png

http://dl.dropbox.com/u/239525/bone%20limit%20rotation.blend

I don’t have Blender infront of me, and you didn’t tell us what the problem was.
I assume the constraint isn’t working for you. Try switching the axis you have selected in the constraint. Also, if you press the ‘lock’ buttons by a property in the transform properties window, it will lock that property and you wont be able to change or animate it.

Assuming you want it limited to the one axis ONLY & not free rotation along the other two?

Simple. You’ve got the right idea: you typed in you z min/max. But the other two axis will rotate unlimited because they are NOT selected to limit rotation. If you want it to only rotate on a single (or two) axis, type in your min/max for the axis then select it. If you don’t want it to be rotatable on a certain axis (in your case the X & Y, right?) set those min/max to 0/0 & select those.

I figured it out.

I needed to redraw the bones.

And also using the Local Space for the bones.

This way it worked.

But it looks like limit rotation cannot work with other constraints like
track to or ik solver.

The rotation limit is completely overwritten.

Asano’s got it, just lock the two axes you don’t want to move in the properties window. Only use the limit constraint for the axis of motion. Atleast that’s how I like to do it because it’s cleaner…

By the way, the IK solver has it’s own limit settings found in the bone options panel of any bone included in the chain. You can set the range of motion there…

Oh I see

you can only get those locks active when using an IK Solver.

That explains why I did not see them earlier.