Limits on zooming in or out?

Something I’ve noticed throughout my years of using blender is that the more I zoom in on a model, the slower the zoom gets, until it won’t zoom in anymore at all. Switching to ‘object local view’ (numpad /) helps, it seems; but is this the only way to zoom way in? I really don’t understand this behaviour. Can anyone explain to my why it works this way, and hopefully how to make it stop doing that? I notice it also only lets me zoom out so far as well, but this is far less of a problem for me. Using different zoom modes (continuous, dolly, etc) changes the behaviour slightly, but it’s still there. Also, I have rotate around selected turned on. Could that be the problem? Perhaps also turn on zoom on cursor? This has befuddled me for years. The only real workaround I’ve found is to change the field of view of the viewport camera, but this is only a workaround.
Thanks in advance :cool:

Hit Del-key on Numpad. And sorry I can’t explain :wink: