Linear Workflow + how to reproduce RAL-colors?

I create a render sample and want to use “real” RAL-paint-colors:
This is very important for me.

i have a list of all RAL + RGB values (Yes… this is not optimal, because RAL can not true converted to RGB, but i think it is OK)

I enabled Color management (Linear Workflow) in Blender 2.55

Now, i want to use this RGB-values and produce rendering that should match this RGB.
OK… shading make the color a bit different… but i think this is OK

I have a bit trouble to match this colors.

For example:
RAL 5002 blue = (sRGB) 0.168627 / 0.172549 / 0.486275
RAL 6011 green = (sRGB) 0.4 / 0.509804 / 0.356863

I created Material with this values
after rendering, i get strange “color shift” - so that colors do not look like in real world.

Can someone help me? I added blend+pic


RAL.blend (95.6 KB)

You should take into account the lights intensity and distance, as well as the reflectivity of the material.
I managed to achieve very close match when disabling the mirror and playing with the light.
Unfortunately that was made in 2.49, and the same file rendered in 2.5 gives different result.

This may not satisfy your particular needs, but in my mind a perfectly acceptable solution is to tweak the colors in the compositor with an RGB node. You could use IDs to isolate the objects with the paint values and color correct them in post.

My idea would be, although i still didn’t fully understand this linear workflow, that your input color is wrong due to your rendering being in linear space and your color is still in srgb space. It could be that you need your color to compensate for the gamma correction in your rendering. Try adjusting your color to something like:
0.168627^2.2 / 0.172549^2.2 / 0.486275^2.2 = 0.0199177 / 0.0209511 / 0.2047105
0.4^2.2 / 0.509804^2.2 / 0.356863^2.2 = 0.1332085 / 0.2271366 / 0.103634

just put them in a test material with diffuse intensity 1.0 and at least the material preview looks more like the color you want

I tested with color^2.2 - and tweak lights
and this produce more realistic - contrast results… without color shifts
so i think, that this was the problem.

I do not understand, why this happen.
When i look to the color management plan:

I should not recalculate colors manually
or i am not understanding the figure
the color picker do not recalculate colors, but blender display “linear color”.

It would be better - if i could choose normal RGB-color and blender convert it to linear when render

oh i understand it now:

The new convention in Blender is to store colors internally in a linear color space, similar to other applications like Nuke that support linear workflow internally. The exact values that you see in this case are the linear numbers

BUT NO WORDS about color^2.2

blenders renderer and the color picker both work in linear color space, so that WYSIWYG. Your color was a sRGB color, and the sRGB colorspace has gamma applied. as far as i understand it thats why you need to recalculate your color value. Imo that makes perfect sense. Maybe it would be cool if the color picker had a flag where you could change the space in which you’d like to specify your color.
You could also input your color through the node editor and put a math/gamma node inbetween your colors/textures. This way you’d have perfect control over everything and wouldn’t have to recalculate it.

I did a render-test with luxrender.
as you see - it look smilar - but much more realistic…
the light is a bit different in lux + i had no indirect light in blender

render time 1h | 250 sampl/px