Lines in shadows, HELP!

What are these funny lines that appear when I render? This is just a cube over a plane and two lamps. These lines also appear in more complex renders, too.


If you mean those blocky edges, they might occur due to the lack of Antialiasing in your scene. You could try to enable OSA (Antialiasing) in the Blender render-menu.

Hey there.

I don’t see any funny lines in that example pic - but I think I know what’s going on.

Are your graphics settings set to “16 bit”? In general most graphics cards let you set the colour depth of your screen.

Each colour on your screen is made up of Red Green and Blue light. (RGB) Without getting too technical, your screen can be set to 8-bit (256 colours) 16 bit (approx. 65000 colours) or 24 bit or 32 bit (each can show up to 16.7 million colours). The more bits per pixel, the more accurate the colour display.

If your screen is set to 8 or 16 bit colour depth then there aren’t enough colours available to show smooth colour transitions - you need to set it to 24/32 bit. Without enough colours to show the smooth colour changes you end up seeing “funny curved / blocky lines” in areas of smoothly changing colour like in your image.

In Windows you can click on the desktop with your right mouse button and click on the “Settings” tab to cnahge your colour depth.


Well, there is a problem called ‘banding’.
You can see that, because sometimes even 16 million colors aren’t enough to display so many shades. There are differend shades because everything your lamp illuminates gets darker the farther it is away.

The problem could also be that a high jpeg compression reduced the number of colours so that the file size is smaller. So if you are using jpg, either set the quality to 100 or try a different format (tga or png).

Some renderers can dither these transitions to remove the bands. I think i heard something like that for yafray, though i’m not sure.

And I was just fixing to ask, “how do you remove the blurring”.