Linked Library

I probably wrong something during the following steps, because something does not work properly.

I created 2 library .blend files:

  1. contains an object
  2. contains a material (of course attached to a local object)

Now I need to use them in a production file, linking them. So:

  1. I Linked the object contained in the first library file
  2. because I need to modify locally the object I maked it a Proxy
  3. I Linked the material from the second file, and I set it to the proxy object
  4. The object is correctly there, and has the correct material, so I saved the project to file

If I open the file again then the object material is lost, the material panel is not referring to the linked material (it is empty), and finally that the controls to select a material or to create a new material are disabled

Is it a bug? am I wrong something in my (simple) steps? other?

I’am using Blender 2.79b


I am tring to split the problem in little steps, so I tried to attach the library material to the default cube of a new project, and I saw that I can save and re-open the file without problems: the cube has the right material

I also tried to Link the pure Mesh from the first library file, attaching it to the default cube of a new project… and again when I save it happens that the linked material disappeared.

Is it a problem if I manage an object that is linked (or that is sharing a linked mesh) that has also a linked material? has it to use only ONE linked feature :face_with_raised_eyebrow: ?

I found that probably there is some problem on attaching the Material to the Data or to the Object in this situation.
By default if I select the material from the drop-down list of the available materials it looks attached to the “Data”, so saving the project the material disappear … that is not what I was expecting.
But if I attach the Material to the “Object” I can save and re-open the file correctly… so the problem looks solved.

The strange thing is that I finally set the Material to the “Object” then the GUI interface has some strange behaviour swapping the combo to “Object” and “Data” again and again … and also it is not showing the same information that will be showed if I save and reopen the project.

This behavior of Blender GUI is confusing me, so I am not sure I found a SAFE solution to the problem :roll_eyes: